I think I killed my Delta Q

So I have an older stock GEM Delta-Q (09), pulled it from my 2009 e2 as I was doing a lith upgrade.
Thanks to @Inwo, got the programmer and reprogramed to the #177 profile and set to default. Bench tested it on the battery - all good.
Fast forward to today.
Installed the new Spark battery - all good, GEM ran great. Time for the charger.
Well, my dumb ass forgot the white wire on the older Delta-Q chargers used to be for temp probes, but when you update the firmware it changes to “Charge enable”. Well, I hooked the charger back up the way it was originally installed.
Red - Red
Black - Black
Green to Green
White to Red/black (I think are the colors in the GEM)
Then nothing - the car would not run
Plugged in the charger and I get a quick sequence to LEDs that run up/down (like 1 -2 seconds) and then the charger goes dark. No power.
Tried disconnecting all the wires so the charger was stand alone again - same, LEDs and then dark.

Pulled the charger and installed a backup, the correct way. White to B- and jumpered the GEM Green to B+ - all is good up and running and charging.

OK, so thoughts on the old Delta Q? Dead for life? Repairable? I checked the two internal fuses and both appear good. Also Red - Green have continuity.

Anyone ??

That should let the car run.
All the gem needs to run is 72v on the green. It wouldn’t run because ac in to the charger removes the 72v on the green.
If you have red, green continuity, and red is connected to B+, car will run.
Charging issue is another issue. Still dead with white to B-?

David - @Inwo
I can’t remember if I tested that or not, it was like 2am by this time. But I seem to remember that with no cables hooked up at all, it would a least power up and have one LED. Not the case with this one.

I am wondering if +72 into the white wire might and fried it. I think that is what the red/black wire in the GEM was putting out, again can’t fully remember. Late and maybe a few adult beverages.

I have it in pieces on the kitchen table right now, I will put it back together and test it again.

Yes, that would do it. The gem should still run though.
I can show you a few things to check. Most important is booting up.
With nothing connected except ac, it should go through an abreviated boot cycle on leds.

Here is a video of it in the GEM with or without any wire connected.

I think thats ok. No better with wht connected, input may be smoked.
There may be isolation resistors between white wire and processor on the daughter board.
If you need to get at the bottom of main board, you will most certainly fail first try. :wink:

3v on white wire, measured to blk.

Here is where I am right now with it. :slight_smile:

Good luck with that. If you succeed I’m sending you my repairs.
Repairs are easy if you can reassembly without blowing up the to-220s.:grin:

Can you send me pic of the daughter board and locations to check ?

I don’t have information on that circuit. You need to trace the white wire traces and components to the pins on the upright board.
Do you have 3v on the white?

Don’t know yet, I have not plugged it in since taking it apart. Should I have 3v on white even with no LED’s? What wire am I using as a ground?

Yes, 3v from the blk B-

Careful powering it up, the copper shields by the to-220 devices are grounded and will arc to +72v traces.
Best to remove them before they break off.

@Inwo - what are the to-220? Just so I know how to kill myself :slight_smile:

It’s the package style of the power devices. Fets and diodes on the side by daughter board.

Yes, I have 3.2 volts from White to Black - no other wires hooked up - no LED’s after the start sequence.

Even if you pull down wht to 0v?
Then I have no idea. :frowning:

I have not tried pulling it down to 0v - I pulled it from the car and took it apart before I did that because I thought it was dead with no lights. I will hook it up to one of my test batteries on the bench and see what I get.
I have no idea if I will remember how to get this thing back together, there sure are a lot of little screws in this thing. :slight_smile:

You dont need it connected to a battery to test it.

Can I just hook the blk and white together to bring the White down to 0v?

Yes you can…