3 wire throttle with Alltrax controller


I have an Alltrax 7234 AXE that I have wired from thier web diagram. I got everything working to the point I got the solid green light on the controller when I hit the ignition, but it’s not doing anything. The throttle they list is 4 wire, and the magura throttle diagram shows it hooked up with just 2 of 3 wires. Neither set up worked from me, I’ve tried 3 different throttles (china escooter type) and I’ve tried all combos of wires between #2 and #3 post of alltrax, nothing happens, and I don’t get the amber light (throttle open) light either. Anyone successfully hooked up a red,white,and black 3 wire throttle to an Alltrax and get it working?

any alltrax I have hooked up are 2 wires to 0-5k pot and the other 2 go to a foot switch,if you connect the foot switch wire (red I think) to the key switch your contactor will be on when the key is switched and it should work,this wire must be live before the resistance of the pot rises or the controller wont work.most of the twist throttles are hall effect which are 3 wire + and - voltage and an output and no “foot switch” check to see if your model my have multiple throttle settings and may accommodate the throttle you are using

Yes, as the last month has passed with more experimenting, it has become clear what vast difference there is in the common china scooter throttles, and that of a 0-5k pot throttle. Once I just got myself a pot at radio shack, all worked well.