My DeltaQ charger isn't charging correctly

Believe it or not it turned on and flashed algo when plugged in. Surprised it didn’t burst into flames. Does anyone repair these?

1 Like

I got you - send it my way, I have an awesome set of tools. :slight_smile:

1 Like

It appears there was a little water incursion problem.

Close it back up, sent it back to DeltaQ telling them it stopped working after driving it through a puddle. If they have a sense of humor they will laugh and write you back a nice story about needing a seal replace for $599.

Maybe it’s the fuse?

1 Like

Overdosed on calcium tablets?
Spray foam insulation?

I love the variety of colors.

Just needs to be put in a bag of rice for a couple of days.

If it were me … I’d tell the wife I need to buy all types of unnecessary tools to fix it - welding kit, chop saw, traeger.

Have you checked the interlock wires?

@JarJarJava - Is there room for it on your next launch to the sun?

Look for what error code the charger is flashing. Should be pretty easy to figure out what’s wrong once you know the fault code

Mine seems to be flashing the right algorithm code but an error code that I’m trying to troubleshoot. I hope it’s not the same error code you might have gotten.

Mikes Charger was flashing the same Error code as the Ocean Gate sub


Plugged it in again and it flashed this code -.-- — …- .-. / …-. …- -.-. -.- . -… I think it’s Morse code. I haven’t used Morse since being on seal team 6. My Morse is a little rusty.

We can repair these, however, the state this one is in is not even worth the future issues from the corrosion.

yeah this thing is toast. But I do have a few others that didn’t get wet and are not working. didn’t know if it made sense to repair or not