I give up - 2012 E6 9 month problem

First I want to thank everyone on this forum for their input to help me figure out what’s going on.

I have nearly replaced every part in my 2012 E6, taken it to two different service centers and I still can’t get the thing to work. I’m at a loss and beyond frustrated and no idea where to go to next. I’ll do my best to document the issues I’ve been having.

  1. Around 8 months ago - I was experiencing a loss of power and it would not go above 15 mph. While trying to diagnose the problem, I was checking the accelerator and when I plugged the 23 pin back in, I was getting an error code 21. I replaced the accelerator and still got the error code 21.

  2. Sent the controller in to R4F and they were supposed to do a bench test, they do the bench test, say it’s bad, rebuild it, I go to install it again and still getting error code 21.

  3. I send it into a local dealer, they say it’s a bad controller so I send the controller back to R4F and the test it again and say it’s good.

  4. I reinstall and think it could be a wiring issue so I replace the 23 pin wiring. Still getting the 21 error code.

  5. I sent it to another local dealer and they say it’s a bad controller, and I have them bring it back to send the controller back to R4F again. They said they didn’t do any work but when they brought it off the trailer, I turn it on and it works! No error codes but still having the same problem with the loss of power.

  6. I do all the testing on my original lead acid batteries (still getting 78V) - I call R4F and he said its most likely a loss of amperage and if they batteries are old to go ahead and replace them.

  7. I convert to lithium batteries and getting 83v to the controller. A day before I replaced the batteries, I start getting an error code 6 while in L gear but I can still go forward and reverse (at the lower reduced speed).

  8. After I replaced the batteries, I can no longer go forward in any setting (H/L) but reverse still works. I hard wire the H switch setting directly P4 at the controller and it went forward (at the lower speed) for about 200 feet then it gives me an error code 6 again and will only work in reverse.

I don’t know what would be possible to replace at this point. I’ve spent over $3k to get me to this point which is exactly where I was when all this started.

What am I missing? What else can I do to get this working?

6 should be a pretty easy one, providing it’s not the controller.
6 means that p3 is low (B-) before p4 is high (B+)

Do you only get 6 after pressing throttle?

I’m still studying your sequence.

1 Like

Pull p6 (turf) to eliminate that from the mix. Can also pull p5, (R ) if you want.
Connect p4 (F) directly to B+. Locks in F.
Then we can move on to p3 (throttle switch)

Problem may be r4f. Did it come back with a fspi rebuild sticker?
Same one or exchange?

Silly question but when you say disconnect P4 do you mean just cut the wire? Or is there a way to pull the wire from the 23 connector?

I’ll have to check in the morning. I believe it was just rebuilt and they sent the same controller back.

The red end of connector can be released and pulled away an 1/8". That releases the wire. Twist and pull out.
If they did not actually rebuild your controller, it would explain a lot. They may have only repaired a perceived issue, and not fixed your problem.

It’s possible to hotwire all of the suspected components, leaving only the controller suspect.
Or borrowing a known good controller would be easier.

Pull reverse and turf wires.
Connect forward at the controller to B+.
Run a new throttle “start” wire from the controller to drivers area to eliminate wire problems.
Connect the throttle “start” wire to B- just before pressing throttle. That’s what the throttle does.
Contactor should pull in with no faults.

I can send you some pinned wires, if you can wait. Cutting them at the 23p connector will work too.

If you still get throttle faults, it must be the controller. IMO
Cleaning and lubing the pins is recommended in the GE manual.

It could be that your technicians were correct in suspecting the controller.
Wish I was there! :slight_smile:


Thanks you so much!

I still have my old wiring so maybe I can chop that one up. Let me work on it tonight and I’ll let you know if I need your adapter.

You would only need a couple wires. Not the rest of it.


Thank you @Inwo! I followed the steps and still getting the same errors. I have removed the controller and sent it back to R4F (for the third time). I’m hopeful they will fix it for good this time and I’ll finally be able to use my GEM. Thank you again for your assistance and I’ll update this thread once I get the controller back.

Convert to Sevcon controller and AC motor - be done with that damn controller forever and get more power, speed and distance.

I’m up for anything at this point. We’ll see what R4F comes back with.

Update! R4F sent the controller back and they ended up replacing the controller. I installed it last night but still getting the error code 6 when attempting to go forward. Good news is that the reverse still works and it appears that the loss of power issue has been fixed with the new controller.

I’m going to keep messing with it but I think I’m close to getting it fixed! Thank you @Inwo for all your help!


Well - I took it in to an authorized dealership and they said because I put lithium batteries in, they couldn’t service it and they sent it back. I asked if I could put the old lead acid batteries in it, if I could send it back to them and they look at it again. They said no, don’t waste your time or money as we won’t be able to fix it.

I’m afraid my only other option at this point is to part it out. I can’t believe I’ve come this far with no resolution. You would think by replacing nearly every part would fix the problem.

Any other ideas?

-6 should be easy if reverse works now.

Disconnect wires 4, 5, and 6.
Connect pin 4 of controller to B+ . That is forward.
At this point, I would cut the wires at the plug.
Connect pin 5 high for reverse.

I’m not even getting -6 anymore. It won’t let me engage any gears because it’s stuck it thinks the parking break is on. I’ve already tried jumping B- to 13 (doing from memory so I’m not sure if that was the one)

Yes, that’s p13.
The Gem also needs to see the parking brake off though.
That is not so easy, unless it is actually the PB switch.

Yes - the PB is off too… I think this is why nobody can fix it - nothing is making sense.

I think it should be easy to sell a non-running E6.
Are you near any members who can fix it for you?
Is it worth shipping it for repair?

I’m in the Dallas area and not aware of any members that can fix. Do you have an idea what a non-working 2012 E6 would bring (with pretty much every part replaced)? I would have to look at pricing for shipping out of my region for repairs. I’ve put so much into it already and debating just cutting my losses.