Hunter 2P will not go

I have a Ruff n Tuff Hunter 2P that will not go in either direction. I have checked the forward and reverse solenoids and the main solenoid which are all working. I also checked the voltage from the throttle to the controller which appears to be ok. Anyone have any ideas. Could also use a manual and Wiring diagram.


Take the wires off the motor and check armature and field for continuity. Brushes could be stuck not letting current get to the motor.

I tried the motor by applying 12 volts to it and it works ok.

Make and model# of controller? Also mfg date if listed.

No numbers on the controller I can find.

Looks like a series motor and controller from picture.
Is this it?

They are available. I can try to get information from company.
500a 48v is $500

Brand ?

In a message dated 3/15/2017 11:15:28 A.M. US Eastern Daylight Time, writes:

No numbers on the controller I can find.

Jinan Keya Controller ?

Hi Kenlhlp
Look at Controller if Led flash any fault code ?

The picture of the controller is close. The control plug is on the left side in a vertical position. It looks like this pic. without the leds.

The plug is a 6 pin on the one in the cart.

ok do you have any picture of controller ?

Kenlhlp, I have an '08 R/T Hunter 2P 4WD that did the exact same thing until I figured out it was the Emergency Brake sensor wire that was shorted out. You can check if that is your same issue by locating the wire under the E-Brake assembly on the floor from underneath the buggy. You will find 3-conducter wires running inside a loose black rubber sleeve coming out of the E-Brake and up the firewall. Needless to say before doing anything with the wires turn off the ignition on the buggy. Then you need to locate the quick connect plug (white/clear color) right in the middle of the fire wall…the wire colors are as follows: From the E-Brake there is a Red, Blue and Black thin gauge wires. From the upper dash there is a Red, Blue and Dark Yellow thicker gauge wires. Disconnect the quick connect plug and use a 3"-4" piece of spare wire or otherwise to jumper the Red and Blue wires together that come from the dash side of the quick connect plug. Warning: Do not jumper any wires to the dark yellow wire…leave it alone as it carries a good amount of voltage. Once the temporary jumper is installed turn on the ignition, push the rocker switch into forward or revers and try the accelerator. I did this and fixed my problem. Hope it helps for you. If it is indeed your issue then replace the quick connect plug, mine was too loose to make the proper connection.

Somewhat same issue. I have a 09 4wd hunter it was doing fine I stopped put in reverse it tried to move but the wheels would not turn noticed status light blinking on controller (sepEx controller). Pulled it back home recharged checked batteties all good. Lights work horn and winch. Push accelerator hear it click and the wheels try to turn then it stops. The status light no longer blinking. I even jacked it up to take weight of if the wheels they may turn 1/4 turn when the accelerator pushed.

I am new to this forum, are these still available, I have one just like it with a 3/2 code with fresh batteries!

The controller?
My 2009 was sepex motor and Curtis.
I’m looking to buy a 2009 as it uses a 19 spline motor that I can upgrade to a BIG ac motor.
The first one I did uses Polaris Ranger EV, motor and Sevcon S6 control.