Has anyone have a code 27

Hi to all, I have 2002 e825 Gem car it’s diplaying a code 27. I have chequed all connections,cleaned them with contact cleaner and does not go away , but sometimes when I turn the key to on it doesn’t display the code and it allows me to ride for about five minutes and the code 27 comes back. I try turning the car on and off but immediately when you press the accelerator the code shows up. It looks is hot and needs to cool off for a while but I checked everything but nothing seems hot our out of the ordinary. Has anyone had this problem before. What will be the solution. Thank you for all the assistance that you can give me I really appreciate it.

Code 27 - 12V internal buss is too low.
This status code will be displayed when the internal power supply of the control dips below 9.35V.

Note: This is not related to the car 12v Acc DC Converter system.

Most likely there is something going on inside your controller but according to the controller manual there may be a few other things that cause this.

Your statement is curious:

sometimes when I turn the key to on it doesn’t display the code and it allows me to ride for about five minutes and the code 27 comes back.

Does this usually happen right off charge? Is this repeatable?

The other possibility is that something is dragging down the 12v bus. Try unplugging your speed sensor and see if the code clears with a key cycle. If you have a meter you can check for 12v on that speed sensor plug.
Use the red and black wires and look for 12v.

1 Like

Hi AssyRequired, good to hear from you. Yes this happened after changing one time I haven’t charged more times because It doesn’t give me enough running time to discharge the batteries. It lets me run at the begging for about five minutes but after that the code 27 shows up and it will not move. If I disconnect the plug from the controller and connect it back it resesets but once you press the accelerator the code comes back. As soon I try what you suggesting me I will give you a rundown of what happen. Thank you and Happy New Year.

What batteries are you using?
How often are you charging them?
When the code 27 shows up what is your Pack V?

There is no need to disconnect the plug from the controller to reset. A key cycle (Off/On) should be enough, or at most a power down via the Battery disconnect should do the trick.

Hi I’m using 4 Lithium batteries 72v each 30AH capacity each for the last year and couple of months . I keep them charged all the time. Today I tried it after charging the batteries to 100% disconnected from the charging plug turn the key on gave me a code 4 put it on forward the contactor engaged and when pressed the accelerator it came up with a fainted code 6 It will not move nor the code 27 shows up.

I just went back and checked what I think is the speed sensor ( the little plug in the controller next to the main plug) and checked every pin there are about eight and will get readings from 0.02 to 0.56 and connected it back the code 6 did not show but when putting the car on forward and dropping the emergency break and stepping on the accelerator the code 27 showed up again and will not move.

Speed sensor has the most direct and easiest access to 12v bus.
Bus is suplied from b+ on pin 1.
Also feeds high side of throttle pot.
Neither sensor or throttle short can pull 12v bus low. In theory. They are current limited.
But if 12v is on the hairy edge of a fault, disconnecting it may show somthing.

No one has asked if the DC/DC recall has been done? This is a 2002, that is always the first suspect.

Mike I really don’t know if a recall has been done I have this car for the past three years and I have fixing it little by little, but I don’t know about what you saying or asking a lot of times . Sorry, but Thank you for taking your time to help me I appreciate it.

No one has asked if the DC/DC recall has been done?

As I read the description of the code it appeared to me that this is internal to the controller.
The PWB → DC converter issue is all external.

the little plug in the controller next to the main plug

This is actually the feed for the round Display on your dash pod. Be very careful about poking around at things without knowing what they are. It is very easy to slip and cross a couple pins in there. Interesting that you did not find 12v at this plug. You must not have tried the correct pins.

When I was referring to the Speed Sensor plug, this would be down at your motor. It is a black thing in the center end cap of the motor and has three wires coming out of it. Disconnect the plug and you can test the harness side when the Main Batt Sw is ON. Use the Red and Black wires.

I would be interested in what your controller is seeing for B+ power when you attempt to go.
Hook your meter leads across the top of your controller on the big cables marked POS and NEG and
Start from a fully OFF condition (main switch OFF) (Do you still have a Main Battery switch?)
Note your PackV when you first switch the Main Bat Sw ON.
Then again when you turn the key on,
Then if all codes are cleared, press the pedal and see if your power drops.

Report back with what you find.
Also- send a pic of your battery install.

In case you don’t understand all of these other codes you are seeing-
04 - Parking Brake is applied. → Drop brake
06 - The accelerator pedal is depressed with no direction selected. → Pick a direction

1 Like

No problem, it was more just a general statement. Anytime someone talks about 12v issues with a car of that year I automatically start with checking the DC/DC converter. You can search the forum and get all kinds of information about the recall. If it has not been done, you should see about getting it done anyway. The old DC/DC converters were known to burn car to the ground.

OK Thanks for the heads up I will check the forum to find out more about that recall. I want to make sure everything is working like it’s meant to be. Thank you for the info.

:worried: Obviously you can tell that I know very little about this cars or other cars :rofl: I’m trying to learn from you Gentlemens and thank you for that and your time. This afternoon when I unplugged that little plug from the controller and plugged back, I turn the key on, dropped the hand break, put it on forward and the car moved put it on reverse and also went on reverse, did it a couple of times, I got of the car to open the garage by the time I open the garage got in the car and pressed the accelerator that 27 code came back. Tomorrow I will go through the steps that you gave me and report to you. Thank you.

Hi AssyRequerid, did everything that you told me here and here’s the report.

  1. Unplugged the Speed sensor plug and checked the volts in the plug and the reading 4.7 volts check all wires and the reading was the same.

  2. Turned the main switch on the reading was 82v

  3. Turned the key to on the reading was 81.9

  4. The controller is seeing for B+ power when I attempt to go 83v

  5. All codes where clear and when pressing the accelerator the power drops to 82.9

  6. After no codes came on I started going foward and reverse a few times and no code showed up.

  7. Since no codes came on I took it for a ride around the block and accelerated very hard and the volts when down to 77.7v for about a second and back to 82 v. No codes showed up. I need to ride it some more to see how long it runs before a code shows up.

  8. Trying to send photo of my batteries but can’t find the file upload botton in this forum.

Let me know if the information makes sense or if I got it right. I think I learned a lot today, not for me to diagnose but for communication perpuses.

Thank you very much for your help I appreciate it.

First, try to stick within the guidelines of the suggestion. Some of the items in this car will not be happy if you go too far off trail. It is real easy to make expensive components go poof.

checked the volts in the plug and the reading 4.7 volts

4.7V ??? Wow- this thing is barely working! I don’t know how you got around the block in this last test. I think that will barely run the throttle.

Try the Voltage test at Speed sensor test again.
Meter set to 20vDC scale(if your meter has that)
Red meter probe to the pin with the Red wire.
Black Meter probe to the pin with the Black wire.

No need to probe anything else in this plug.

See if this car will run without the speed sensor plugged in. It May error out with an 81 or 82 in which case plug it back in and run test again.

Keep watching the V at the controller in your run tests. I still want to see what it does when your 27 shows up.

Also- To Add a pic or graphic,
Use this tool when the editor window is open.

eforum insert pic

1 Like

Hey AssyRequired believe me I’m trying to follow your suggestions as close I can or I think I’m doing. That’s why I don’t do anything else unless I get a recommendation from this forum because I know very little from this car. I recheked the speed sensor plug again and it still gives me a reading of 4.6 volts. I left it unplugged and went for a ride of about 1 1/2 miles I accelerated it to it’s maximum speed, about 26 mph, it performed excellent and no codes came on. Don’t know if raiding it farther will light up a code because it is night time to dark to ride more distance.

What can you diagnose and what will be the fix to this problem. Thank you.

No worries Arthur,
I was just infusing you with needed caution.

For now, run around without the Speed sensor and continue to watch for the code 27.

I really want to keep an eye on the PackV to see if this is causing the error.

Doing more research here and will check back with more input.

Ok thank you, I will try to ride it longer to see if the code shows up. I appreciate it, thanks again.

Hi Assyrequired,

When today on a ride with the car and while running I was monitoring the volts in the controller and where always 83v or 82.7v except when accelerated hard to full speed that it will go down to 72v briefly and back to 83v when it stabilizes. I checked some wires that are not connected to anything and one gave me 13.4V and another 0.05v but I don’t know what they were use for. I almost forgot the 27 code has not showed up so far. I’m riding it with the speed sensor disconnected. Let you know when I have more information. Thank you.

1 Like