2001 Gem Car Code -27 Problem

Hello Gem Community,
I have a 2001 Gem E825 4 seater that I bought on CL used with wasted batteries. I promptly put a new D&D 11 HP “Blue Motor” (same as Ride 4 Fun) in it. I also had my Zivan charger rebuilt and updated. I put all new brakes, bearings, added disc brakes, new batteries, and a new E-Brake handle assembly. I sent my controller to OC Monster Carts for reprogramming. When the controller went out, it ended up having to be rebuilt and sent to GE. When I hooked everything up and drove it, I would sometimes get a stutter and a random code -27 (low 12v). The DC/DC converter has been upgraded and I actually added a digital 12v gauge on my dash so I could watch the volts, it has been steady between 13.1-13.4V the entire time. I sent the controller back to OC Monster Carts, they sent it back to GE and no one could replicate the code. GE sent me a BRAND NEW different controller, which I immediately was getting a code -41 (overheat), I sent the controller back again, they worked on it, sent it back. Now I am NOT getting the -41, but am still getting the random code -27 and the car will trip out. If I turn the key off and then back on, the code clears and I can drive the car. I have also noticed that it stutters occasionally on acceleration, which sometimes coincides with the code. I have cleaned the connectors on the controller with electrical contact cleaner, and took the plug apart to clean everything as well. I also checked the motor and all the connections. I took the pedal apart and sprayed contact cleaner on the potentiometer. The only thing that I can think of now, is maybe the pedal is faulty?? I am really out of ideas and OC Monster Carts (Chan and Alan) are also stumped on this one. I am about to order a new pedal in hopes that this solves it, I have looked at all the wiring and the harness and can’t find anything. The fact that I am getting the same error code with a different controller eliminates that controller as the issue. I don’t think the motor is bad, it is brand new from D/D and ohms out properly. Hoping someone else here has had the same issue and can shed some light on this for me.


That’s not the 12v that code causes -27 .:wink: It’s the controller low voltage buss that is being pulled low.

The only external wiring affecting that is the 5v acc voltage and 12v tach supply.
Buss can be monitored with sentry sw. Or a meter on the tach 12v lead may show it dropping.
I would expect to see tach signal error, but if something is shorting the red wire to the tach, the -27 may latch first.

Sorry I am not familiar with any Tach on my GEM. I don’t really understand. What is Sentry SW? Is the 5v the speed sensor? A little more English for me, I guess I’m not sure where to look here.

Thanks for your help.

The tach sensing unit is on the end of the motor. It is powered by the 12v buss in the controller.
Red is +12 black is B- green is pulse. The controller uses the tach pulses to compute speed, miles, and power sent to the motor.

The programming software for ge controllers is called sentry.
It allows you to monitor what’s happening in the controller.
It will make a graph of things like motor current versus buss voltage. OR at least watch them while driving.

As you are confident in controller being ok, then something is amiss with battery circuit, accelerator, or tach circuit.
All the outputs are protected except maybe the +5v supply to bdi.
It might be worth a shot to unplug the display. Not sure if car will run without it.

I have noticed that my Speedometer BDI display is sometimes missing the LED lights on parts of it, I just assumed that the thing had a bad LED, but maybe the actual display could be the issue here? I guess I could try and find a new one and replace it and see if this solves the issue. Sometimes the display works fine and sometimes it is missing parts of numbers like zeros. I hadn’t thought that the actual BDI could be causing this???

It’s connected directly to the dc buss.
If car runs without it, see if it quits. It’s a long shot.
Some cars will run without the tach in limp mode. Not well enough to test for the error though, maybe.

Just ordered a new BDI and pedal. Going to replace both and see what happens.

Installed a new pedal and tried two different BDI’s. Both of the new BDI’s went haywire with very strange readings and the lights and indicator going “Crazy”. When I put the original back in, it was normal again. Not sure what the deal is here, but returned both of the other BDI’s (remanufactured) that I tried. New pedal is installed. I did get the random code -27 with the haywire BDI display as well so that is not the problem. I am literally out of ideas on this cart. Someone has suggested a bad wiring harness, although I see no evidence of any problem with it. After I get the code and the cart trips out and has to be reset, the BDI always shows a false battery % reading that is substantially lower than actual. I had to get towed home the other day because of this, and it has happened twice to me. I am not comfortable now at intersections always worried that it will trip out on me in the middle of an intersection. ANY ONE OUT THERE HAVE ANY IDEAS???