Need help with component diagnostics!

1st timer here. 2003 e825 that has been tweaked by previous owner with a Delta-Q charger & a Sure Power 71030i DC-DC converter. Ran great for a few years then the batteries aged out. new wet cells, then the Delta-Q died. Installed a Ride-4-fun charger, works OK, but didn’t drive 100 yards and the kicked out. seemed to be switch on accelerator, so upgraded that and the parking brake switch. Don’t know if I torched something during the charger swap, but won’t run at all now. error code 57.
Going through the troubleshooting steps and it’s pointing to the motor controller, but getting strange feedback testing voltage at the Main Contactor. Does not ‘click’ like it should, but reads 72v on both sides. Does anyone have tips for bench testing these components. It could be the controller, the contactor or the converter…or some random gremlin. I have the electrical wiring schematic that is a nightmare to decipher.

Ok, Lets break this down and check a few things.

Start off with your battery pack. It sounds like you might have a dirty connection. It is VERY important each cable is clean and bright. Both the battery and cable lug.

Start off on one end and go to the other. When done, make sure each bolt is tight.
Measure that battery with a meter and write that number down for later reference. When moving to the next battery make sure you have the next one in the right direction. From your other post it sounds like you do, but check anyway.

If the main contactor is not clicking this means something is not passing it’s safety checks. This usually throws a code. Pay attention and keep track of those codes. Some of those codes can be a bit obscure but we can usually figure out what the controller is complaining about.

Your observation of 72v on both sides of the contactor is actually normal. Inside the controller is a precharge circuit to charge it’s capacitors. This precharge prevents the big spark on the contacts from the massive inrush current that would happen without precharge and saves the contact points on the contactor. This being said. I have a test to see if your contactor is having issues, but we will come back to this after you check your connections on your batteries.

1 Like

Battery connections are great. Wet cells, and I just topped them off. Getting 88v. Just did a hack to test the contactor. Disconnected the black/green and jumped this lug to ground. Contactor worked with the key and cart runs. Continuity is fine on this wire to pin 11 on MH20 so making me think faulty motor controller. Any other things I should be looking at 1st? This cart doesn’t have a PWB, & the lock-out timer and adjacent relay both appear to be functional. As does the Sure Power DC converter.

You jumped the solenoid lug to Ground? or B-? (note there is a difference)

Once jumped, and cart runs fine, does the PID display any codes?
Sounds like you figured out that P11 goes to ground when the controller tells the contactor to close. Can you check if it does? Make sure the 23p connector is clean. Give it a shot of contact cleaner and a blast of air.

Thanks again for your input. I jumped to ground. Key on contactor engages- no code. Key off contactor opens and BDI shows 8888 & does not shut down. Undo jump to shut down.
Was concerned about the MH20 connection at the controller (still am, with all these aging connections) so already shot with contact cleaner and a brass brush.
I’ll try jumping to B1 and see what transpires.
Is there a wiring diagram out there that shows the actual circuits? The factory schematics are so disjointed that it makes it almost impossible to chase down problems. If not, I’ll probably draw one up from scratch. I’m on the verge of slicing open the main harness so I can check and chase every wire.

Harness diagram is available. It is rough. Agree- The service diagram is disjointed. All of this has the possibility of a being even more inaccurate by a service update that your car may or may not have. Then there are the creative wiring additions by numerous previous owners.

Be aware that the main battery pack (B-) does not connect to frame ground. Whenever you are dealing with Pack V (~72V) always go find B-.

I am somewhat surprised that your jump from your Main Contactor to frame gnd even worked. It must have backfed through something. But that is always risky and hopefully something didn’t get too upset about it.

If your BDI does not shut down when KEY OFF, it may simply be held active by the Time Delay Relay if your car has the update.

Maybe we should check all your 12v grounds? I find it odd that a jump to your MC will hold the acc circuit high until removed. That should all be part of the 72V B- wiring.

Hopefully you were a little careful with that brass brush on the pins. There are a few caps in there that might still have power on them. Jumping to some of the other pins may not be good.

This cart had the service upgrade. So understand that PWB on manual schematic is now 5 separate components. Adds joy to the confusion.

Jumped contactor to B-. Key activates contactor regardless of parking brake (verified functional) position.

Lock-out timer deactivates contactor regardless of accelerator position (switch also verified functional).
No fault codes.

My contact cleaning was limited to the MH20 harness socket. Did not dare touch pins on controller. I take pride in not confusing my ignorance with my stupidity.

Oh mighty GEM guru AssyRequired, does this look like some DisassyRequired of my motor controller?

I’m not afraid, and have years of experience in taking things apart Then tossing them. Just don’t want to be stupid here.

Do you have the wiring instructions for the service update? It has a few pages of wiring diagrams that should be included in your library.

I believe 03 was a year that did drive with brake pulled up. If you really want that feature then we should tap into the proper wire that will make that work properly.

you said →

Lock-out timer deactivates contactor regardless of accelerator position (switch also verified functional).
No fault codes.

Are you saying the inactivity timer will eventually drop the power to the contactor?
Footpedal will not keep it active or re-energize the contactor?

Q- When running with it jumped, does the PID show any speed?

does this look like some DisassyRequired of my motor controller?

Sure- If you like. It might just provide us with some hidden clue. (bad/cold solder joint, broken trace, corroded pins from water ingress, crater on board where there should be a needed component)
Watch/beware of those pesky caps!

Or- if you like, we could probe the pins on the controller looking for lack of the correct V on one of the pins that tell it all is good to go.

OK, I backed up. Reattaached the blk/grn to the contactor - and retested troubleshooting steps 7 & 8 as my initial testing used chassis ground instead of B1-. Voltage at blk/grn with switch on-off-on is 72v-0v-72v. Repair says to replace contactor, but contactor worked when jumped to chassis ground. (did not try jumping to B-, but I just might try that).

I’ll try to remember that the return key is a shortcut to ‘send’. My '03 has the parking brake lock out and I’m OK with that. I do not have the wiring instructions for the service upgrade, only the generic Sure Power pin guide. I am now getting error codes. Brake off, pressing accelerator, forward direction gets me a 66. Reverse gets me a 57. I would like to try probing the controller pins as a 1st step, feeling confident that there is an issue starting at pin 13.

I think your contactor is OK since:

  1. you are reading 72 on Bk/Gr
  2. When you ground that side of the coil the contactor closes when Key ON (but I don’t understand why) (this should go to B-)
  3. You say the motor runs when jumped and you press the Accel pedal (verify?)

→ Do you get speed on the PID when motor running? (verify?)

Note: You need to be referencing B- (not b1-) The best place to pick up B- is on top of the motor controller. (You may be doing this already and may be just referring to it incorrectly.)

Reading 72v with wire installed, key on, grounding to B-. wire disconnected contactor terminal jumped to chassis ground, key on activates contactor and motor runs and get speed on PID (innaccurate, but that’s another story). I havent tried jumping to B- instead of ground. I’ll do this within the hour and report how that goes.

OK. disconnected blk/grn @ contactor - and jumped contactor - to B-. Key activates contactor. motor works for 2’ then shuts down, just as if I turned the key off. contactor off and BDI blinks milage, then 0000, then off. Key off and back on reactivates BDI and contactor. forward/reverse same symptoms.

if key on and brake set, lockout timer shuts off contactor as intended.

Are you running car on stands or are you actually rolling 2 feet before cutoff?

And when it is cutting off at 2 feet, is the contactor kicking out? Or is the controller pulling off power?

actually rolling. 2 feet, about 2 seconds of accelerator activation, then acts like I turned the key off. contactor disengages, odometer reading displays for a bit, 0000 on the BDI, then all off. turn the key off then on & it resets to acting normal.

Think the controller is calling the shots here.

Getting a little confused on the threads here, so jumped back to this one.
Controller is a T2. no capitals in my email address. Pretty sure I can pull the PC boards out of the sealing goo on each end so I can get a better look at both sides of both boards.
The motor is a 7hp from Ride4fun. This cart has some wickedly tall gearing, and I sent this controller to Ride4fun to re-calibrate the speed. The speedo reading was further off when I got it back, but didnt want to pull it out and ship it again.

What other threads are you reading?
Yes- It can get very busy when multiple suggestions and directions are offered up as solutions.

Don’t go pulling at the PC board just yet. I want to go in another direction first.

As I had the T2 controller out, open and on my bench I did some close visual inspecting and probing of the mosfets. Everything looks good visually. no blown caps, to burns. one mosfet tested bad, so I have one coming. May or may not be the cause of my woes, but it’s something. Pretty sure I can replace that component without tearing up the T2.
Its the mosfet on the far left.

What other direction do you think we can explore?

Here is a thread from some of our legacy members that more/less goes down your path- Some of this is on later controllers, but I think it all applies.