Need help with component diagnostics!

Where I was going next was to have a quick look at your motor. Depending on the last time it was done, It may be in the need of a service. Sometimes a bad contact on the brushes can cause some pretty big spikes on the feeds. These can take out a controller.

Depending on your motor, at least take off the inspection cover and blow out the black carbon dust. Give each brush spring a flip and see if a brush is stuck. See if you can get a good look at the comms as you slowly roll the car a bit forward/backward.

An audible clue would be some low level grumbling and maybe even some sizzle-popping when under accel. It’s easier to hear when dash is off for a test drive.

As this cart has been sitting unused in the weather for a year or so, I’m planning on going through everything. I’ll put the motor on the list. It’s a 5 year old 7h with probably less than 300 miles on it. Brakes, bearings replaced 5 years ago also, but sitting is a slow death. Repairs and painting the abs pcs too, but none of the above until I have a runner.
Have a rewarding year’s end holiday season. I’ll be getting back on this after the 1st.

This is EXACTLY why I ask so many questions. What first looks like a simple problem sometimes has deep roots in other parts of the car.

For sure- pull that motor and get it out on top of the bench before trying out your repaired controller. It comes out easy and far easier to get to all the way around with the motor on the bench.

  • You may not need a full rebuild, just start with pulling the band cover off the end and inspect each brush to make sure it is not stuck in it’s holder.

  • Blow out all of the dust(do it outside).

  • Meter all the connections.

  • put a finger of spline grease on the coupler


→ As per those other threads, You might want to replace all of the FETs in the group while you are in there.

There are 2 Fets of this type in the T2. Replacing both.

If it’s been sitting in the grass for all that time, and stuff is rusty and crusty, check the wires attached to the brushes and make sure they aren’t corroding. The last thing you want is for one of them to break and arc onto the brush holder.

Where’s your sense of adventure?

No adventure needed. Luckily I caught it before it fried the controller.

Bloody spectacular mate! I bet that smelled wonderful.

Thanks for the tip. I’ll pull the motor and check it out. The original motor died like that.

Ok, I have replaced the 2 fet’s in the grouping and they tested OK. reinstalled the controller and same symptoms. no contactor engagement, 57 & 66 error codes.
I manipulated connector MH20 at the controller and BDI blinks to 04, making me question all the contacts there. I am now chasing all the wires and connections for any faults. If everything checks out, I think its new controller time.

I assume you checked out all the FETs before putting it all back together.

Are you getting the 04 consistently?
Have you tried lowering the parking brake to clear it?

Did you go through and/or check out your motor?

I did check all FET’s. The only area of the controller that I couldn’t visually inspect was the bottom of the lower board, as it was locked in by the end cap sealant globs.
I took apart the MH20 socket and carefully cleaned and tightened each female terminal (using 10x glasses, feeling like a micro-surgeon) 04 issue fixed, and now the contactor activates correctly. Sort of…
Today I pulled the motor. It was a mess, with 3 of the brushes seized in their housings. Did a complete disassembly & cleaning including polishing the commutator on a lathe. Reassembled and reinstalled.
So I think I have fixed at least 4 issues.
Remaining problem is the the cart shutting down after going a short distance. Symptom is like the ig. switch is turned off. -contactor disengages, -BDI goes blank, -no codes. Turn ig. sw. off then on resets to normal, until cart goes a short distance. Problem consistant in both modes and directions.
I am now going to verify the accelerator micro switch is functioning normally.
Think I’m getting closer to cornering all these gremlins.

Momentary Throttle switch issues would not shut off the PID.

Monitor the V from the converter. If it takes a dive then look at the key switch or the DC-DC converter is shutting down due to a short.

Just to recap cart 's current issue, after MH20, controller and motor work:

key on, brake on=04 @BDI; brake off charge level then speed @BDI (normal); accelerate and within 2-8 seconds the cart acts as if the switch was turned off, contactor disengages, BDI displays milage, then 0000, then off. So a random ‘key off’. I call this “dropping out”.

Following your advice, adjacent the converter I hooked V-meter from red to chassis, then orange/green to chassis. Interesting things (clues?) observed.

No change in voltage when cart drops out.
BUT, observed that voltage DID drop when the brakes were applied. Red dropped 13.3 to 1.1; O/G dropped 13.3 to 8.1. Disconnect either upper lead on top brake switch and voltage does not drop. Normal?

Could this key switch drop out emulation be a controller issue? or is it a wire/switch issue?

I noticed a 2 wire harness coming from the steering column that had been cut. Assuming this happened during the PWB conversion/upgrade.

This is ruining my dry January!

Have you hardwired the key switch? Sounds like the key switch is opening or a wire is opening.

Does not explain the footbrake voltages tho.

There should not be two wires in the steering column because of the PWB conversion.

If it is a two wire wrapped in a gray insulation then it might be the old led charge indicator. How disappointing. Someone was lazy and cut it.

If we are assuming this is a simulated key switch OFF, and it dies like you describe, What do you do to get the car rolling again?

Do the brake lights actually work?
Does the car drive normal with the brake light wire removed?

  • Tip- Don’t feel like you need to actually drive the car. Put the front wheel up on jackstands.

Interesting observation on that O/G wire. I have that as the interlock wire that is supposed to be brought to ground through the keyswitch to go. You have voltage on that?

Which red are you grabbing?
The reason I ask is that it happens to be the #1 favorite wire for POs to use when wiring up fun things in their car.

Since your PID is looking like it is shutting down properly then I might guess it still has unswitched power. Let’s look at the SWITCHED power. Maybe it is going away?

Does your 03 have the black DC Converter (surepower)? Trace the wires coming out and check the colors. Ignore the wire claiming to be the ign switch in this diagram. That will be triggered by something else.

You might be seeing something like this:

Have not played with the key switch, but will do that.
footbrake voltage issue seems separate of the dropping out. possibly a short between 12v & 72v somewhere. Out of frustration over these mysteries I opened the main harness so I can verify integrity of all wires. Thanks for input.

I agree about the 2 wire.
when the cart shuts down, I turn the key off then on and it resets to normal, and acts so until I accelerate and it drops out again. I’ve done this 2 dozen times and it acts the same every time. Only variation is sometimes 1 foot & sometimes 8. It consistently resets to normal with key. Very strange.

the 12v wires I monitored were RED which on my surepower is terminal 7&8, and Orange/Green which is terminal 9&10. I did this near the surepower.
FYI surepower other terminals: 1=green, 3=blue, 4-6=black, 12=white. so same as your schmatics, except that i had a DeltaQ that died and was replaced by a Ride-For-Fun charger.

The cart worked for 1/2 mile after installing the R4F charger, so I called them (at the time, a year & 1/2 ago!) and explained the situation. Was told that it was impossible for it to be the charger and to start looking at the microswitches on the parking brake and accelerator. Has not run since. I will check the lockout on that charger along with the key switch.

I did not verify the brake lights working, but I suspect a short somewhere. I was getting strange intermittent 72v readings, including at the fuse block. Seems normal since I opened the Main Harness. Will look carefully at all wires.

Thanks for the charger schematic. Will be very helpful as I trace & verify all the wiring.

I’m out of town, and hope to get back on this on Wednesday. Thanks!

Thanks for the history, It helps when we know more of the background.

It also helps knowing what you are actually probing. There are so many cars out there it is sometimes tough to guess when people try and describe (I used the xx wire).

Keep in mind whenever you are testing for Pack V you need to use a good source of B- for reference (NOT chassis ground). Strange results will drive you nuts.

As you note- when ref 12v you can use chassis ground, but it might be a good idea to also do a test ref the black wires coming out of your DC converter. A bad/dirty Ground connection will also drive you nuts.

The Red wires on 7&8 (switched output) dropping to 1.1 when pressing brake is a concern. I have no idea why you haven’t blown a fuse on that much of a drop. (hence my bad ground comment)

The same for the O/G on 9&10(unswitched) should not be dipping either.

Do the same (brake test) but monitor the B+ and B- input voltage and report back with what you see. Tell us where you are measuring this.

You have been though a lot here. I went back and reviewed the complete thread.
When you get back in town I want you to measure/watch the Pack voltage directly on your controller when you activate the motor and try and go.

Today’s observations/tests.

  • Following your advice, I always use B- for battery pack voltage.
  • I verified black leads to chassis as a good connection.
  • jumped the ig lock. No change, and it tests solid on ohms.
  • jumped/tested charger lock-out leads. They are OK too.
  • checking out the leads at the relay I find some puzzling results which are leading me to suspect a 12v-72v cross connection, or something similar.
    my relay conductors match the Zvan schematic. As I read it, White=72v+, Green=72v-, Black=12v-, so my assumption is grey/white should =12v+. Also assuming 12v on should activate 72v on. Correct me if I’m wrong here.
  • Pulling off White, it tests 72v to B- with switch on or off. 0v to chassis w/switch off. 88v to chassis with switch on.
  • Grey/White tests:
    pile on, sw off=62v to chassis ground, that slowly climbs to 72v (1v every 3-4 seconds) .
    pile on, sw on=12v
    pile off sw off or on I get an intermittent 12v or 0v reading to chassis ground.
    Another wierdness is when I road test on the ground cart drops out 2-5 seconds. testing on a jack wheels spin for about a minute. maybe due to less load?
    I’m ordering a new relay, just because its a cheap test. Tomorrow I break out the bright light and the big magnifier, hunting for breaks or chaffs. I did not do the B+to B- test brake test, but will.
    It’s obvious some component can’t handle amperage. But I’m doubting it is electronic in nature as I would seem strange for a capacitor or transistor to heal itself after a failure. But I’m no electronic’s guy so I could be way off on that.