GEM Service in Austin TX

I recently purchased a 2014 e4 and I am located in Austin, TX. I took it to the closest dealer (Kent Power Sports about 30 mi away) for some service, and i could not have been less pleased. I am now having some electrical issues (assume its the DC-DC converter), but would love to have a pro troubleshot & repair . . . but I can’t find anyone willing to work on the GEM.

Anyone have any ideas or recommendations of anyone local to Austin that would work on this, or any suggestions on how to find someone?

If you don’t have a good shop you can trust close by then the best mechanic might be yourself.

What are your issues? Maybe we can help sort them out.

What is your skill set and what is in your tool box?

I was thinking the same thing, and that is what brought me to this forum, but after researching I feel that I may be out of my depth.

I am fairly handy, but don’t has a lot of experience with electricity, batteries and electronics. I have a pretty robust tool chest, just probably need to add some voltmeters and other electrical testing tools which I am not scared to invest in now that I am a GEM owner.

To my issues, my horn, wipers, lower rear lights and license plate light are not working. The front lights and signals, the rear upper break light and the wiper fluid all DO work. I have checked all the the fuses and they appear to be closed. I have checked any of the obvious connections under the hood and cant find any that are lose or suspect.

It seems like everything that’s out, except maybe the wipers, are on the #1 fuse run. Any suggestions on tools to grab and what to start testing would be greatly appreciated.

Have you swapped the #1 fuse with a new one or just one from another slot?
Sometimes they “look” good but are actually bad. Just takes a second to try it.

I bought a brand new pack of 10A fuses and actually tried 2 of the new ones just in case.

I took it to the closest dealer for some service,
I am now having some electrical issues

Refine this statement a bit more.
What service did you take it in for?
Were these electrical issues happening before? or only surfaced after the dealer did their service?

Not that I like spending other people’s money but having a meter can be very handy around the house, but also now that you own an electric car. I’d be happy to run you through some basic meter operation.
Stay away from the super cheap ones they are almost giving away because sometimes they are not very accurate. Odd readings can drive you nuts and waste time sending you looking in the wrong direction.

10A fuses and actually tried 2 of the new ones just in case.

That was a good attempt. I was going to suggest this too.

How much exploring under the dash have you done? That is next. It sounds like we need to get under there and inspect a few connections.

Refine this statement a bit more.
What service did you take it in for?
Were these electrical issues happening before? or only surfaced after the dealer did their service?

I rescued the GEM from my brother in law that no longer used it. It had sat, uncharged or unused for about 6 months and wouldn’t take a charge. I took it to the dealer and they initially said needed new batteries for $6k (has about 24 month old gels in it) and a new motor for another $6k. I told them to pound sand and to please just charge each battery for me figuring I’d buy a new GEM before giving them $12k. They called me the next day and said actually it just needed the batteries charged and it was now up and running fine and holding a charge. Clearly I will not be taking it back there.

My bro-in-law said he thought everything was working before, but he did use it pretty sparingly leading up to the 6 month sit, so its possible the items were out before the long sit and then the service and he just didn’t know it.

Not that I like spending other people’s money but having a meter can be very handy around the house, but also now that you own an electric car.

I agree its something that I just need to have around now that I have a GEM so I will order one, do some research and let you know if there is anything i can’t figure out. Appreciate the offer to help. Let me know if there is a brand / model that you prefer?

How much exploring under the dash have you done? That is next. It sounds like we need to get under there and inspect a few connections.

Very minimal. I opened it up and jiggled / pressed together any connections that were in view or readily accessible. I just got a copy of the service manual from Old Houseboater so I was planing to start doing some more targeted investigation, but to be honest, I’m a bit scared to do more damage than good as I have never worked on an EV before.

That shop that wanted $6k for batteries was a BIG red flag. Scratch that shop off everyone’s list. Tag them please.

1 Like

Sorry, I’m new to the forum and not sure how to “tag” them. It’s Kent Power Sports in Kyle, TX. Authorized Polaris dealer and who GEM customer service told me to take it to. Without getting into too much detail, there were a lot of red flag items out of them aside from just the price tag of the batteries. I would not recommend anyone go to them for service.

1 Like

6k for batteries
6K for motor

Good lord! That must be a really cool set of batteries. Same for the motor. This must have been some sort of “New Owner” test by the dealer. I’m not sure if you failed or passed.

Your list of what works and what doesn’t is quite puzzling. It sounds like more than one issue is going on here. It sounds like you have at least some level of 12vdc pumping around, so that is good. Plan A is to check a few plugs on the front of the PSDM (main fuse block thingy) and see look at the individual harness connections.

lower rear lights and license plate light are not working

SWAG - This may be the small 4 pin connector running across the top if the batteries under the rear seat. It is a little 2x2 molex? that has a Vt/Db, Bk/Db, and Gy/Db in it. I think all the grounds get tied to the frame but since the dealer was working on the batts maybe they unplugged it and did not put it back?

Oh, and the question I keep forgetting to ask:
What does it do when you KeyOn and does the Dash light up, no errors, and drive?

Only two? Come on, one more for the hat trick. Please?

6k for gem batteries could easily be those pre-fab lfp units like Allied sells. Those are around $1200 a “battery”. OK for a 36 or 48v golf cart with low draw, but a GEM that pulls 250 amps on launch and is expected to have 20+ mile range at 25-30mph will turn those to mush quickly as GEMs are not 1-2 miles at <5mph like a lightweight golf cart.

Thanks for the starting points, I will check these things out and report back.

When I key on, dash lights up, no errors, drives great, has great range and tops out to 25mph super quickly.

Finally got a chance to carve out some time to poke around. Was able to get the back lights and license plate lights working by finding that molex and reconnecting it. It wasn’t obvious as both ends were tucked back up under batteries, but i think that you nailed it that the dealer unplugged and never reconnected. THANKS! 50% of the way there.

Now the only outstanding items are the horn and wipers. I have a multi-meter on order so I plan to check the power to those connections once it arrives. I understand that it is not uncommon for the wiper motors to go out . . . they seem pretty pricey so hoping that it is something more simple on that.

Yours is a classic body gem right? I’ll look later and post here, I think I found reasonable pricing on wiper motors a few years ago when I had to replace one. I want to say about $90 less than the average price, but don’t quote me on that

Pro-tip: shove a rag in the trumpet when working with the horn. It’ll keep concerned neighbors out of your garage and running off with your beer and your tinnitis from getting worse (somebody get that dang phone!!!).

Horn- When pushing in on the stalk (supposed to be activating the horn), Give the horn module a few quick raps with a screwdriver handle.

Alternate- If power actually found going to the horn and it still is not working-
Look on the side of the horn for a screw held in place by a lock nut. Loosen the locknut and give the screw a little twist back and forth. Readjust and lock the nut when tuned to a nice smooth C/sharp. (or is it G/sharp?)

Wiper - Do you have all 3 wires going up to the wiper? or has one come off?

Here’s the wiper motor that coimes up on the link from my receipt.
Although I’m not sure it was a 100deg sweep or if was slightly less.

Multimeter came in and was able to test some stuff out. Wiper was getting proper power, but looks like one of the terminals on the wiper motor was all corroded and hanging on by a thread. I just ordered a replacement as the entire thing seems to have been exposed to some elements so I figured I was better off just starting fresh. I would probably just do without but I need it to pass state inspection here in TX.

Horn was not getting power. I tested the horn on a different power source and it was working, so now in need of tracing that back and trying to find the problem. I assume it could be something from the PSDM to the horn itself, or even the stalk not sending the request.

Appreciate all the help. Even if I am not able to get these 2 thing going, I feel like I know this vehicle 100x better as I have damn near taking it completely apart!


Horn - the power for the horn comes from Fuse1.
Note: The headlights are also powered from F1 so if they work that means the fuse is OK.
Power comes off the PSDM J3 and heads to the switch, then comes out as BRN/Gy and back to the PSDM on J3.
It comes back out J1 (front harness) as a GY/DB and runs to the horn.
If you just want to get it to pass inspection, mount a button on the floor and run a wire to it as a temp fix. Having the horn on the stalk is kinda weird anyway.

Wiper- Power for the wiper comes from Fuse 7. The Wht/DB is the park wire and should have Keyed but always ON 12v power on it. The BRN wire is the switched power from the stalk. Ground is usually to the chassis. For some reason there are many that have the black wire run up to the wiper and the tab seems to be broken off or not even added so the wire is free to wander around.

New wiper motor came it, but I can’t get it to turn. Mine has 3 wires: White/Blue which appears to be the park as it is getting about 13.54v steady when keyed, a Yellow/Blue that gets the same 13.54v when the stalk is engaged, and a black which should be ground which I just left dangling.

The new motor indicates that left terminal is park, top right is high and bottom right is low.

Any suggestion on what I’m doing wrong here.