EL sputters then stopped

I have an EL with aluminum pickup bed that we use around our property and surrounding cycling park. It has been a great help thus far. We keep the batteries charged on a regular basis and it showed full when I unplugged it this morning. It started sputtering today and not wanting to move forward or backwards except in little spurts. The dashboard started displaying the turtle logo in the begining when the issue started. Over the course of the day we tried it several times and the problem got worse. Jiggling the ignition key seemed to help but then not. The 15 warning came on briefly. The dashboard refuses to light up at all now and the EL is inert.

I tried to start it today after letting it sit all night. The dashboard came to life twice but i could definitly hear a relay clicking on and off that corresponded to the dash lighting. Twice and then dark again.

Pull the dash surround apart to get at the back of the ignition switch and jump the two wires together. If it works after that, replace the ignition switch.

If not - check all your battery cables and the cables under the dash and hood for any loose big orange cable ends. Do this with the master switch off, of course.

Yeah! so far we are working again! I have just put in a toggle switch for now. Of course I will order a new keyed switch once I find out where to purchase one. :slight_smile:

I’ve been happy with the Echlin switch listed under the alternate parts sources topic. It’s not as secure as the OEM Medeco switch but it costs a heck of a lot less.

Ok. I can’t seem to find that listing but I will continue digging.

Echlin KS6040 from your local Napa autoparts store. It may not fit exactly the same, but it’ll fit with a little filing of the aluminum plate the switch mounts into.


Please email me at thanson206 at gmail please. I have a couple questions. Thanks!