Charger won't do anything?

New owner of a 2002 GEM 4-seater, and have encountered an issue that I can’t find discussed anywhere… This GEM had been sitting neglected for years, and when I plugged in the AC cord to charge, it produced an error indicating that the batteries were dead (surprise!). I purchased 6 new gel batteries, and it is alive! I plugged in the charger, got the indicator LED on the dash to light and heard the charger fan. Charge level indicated 100%. I then focused on the multiple corroded connections to the lights, turn signals, horn, e-brake, etc. I now have a GEM that goes, with lights that work.

All this brings me to my current issue. I plug in the AC cord to charge (batteries are now at 75%), and nothing happens. No LED, no fan noise, and when I turn on the key, I don’t get the charger-is-plugged-in error code. I could drive away with the power cord attached if I wanted to. So the GEM doesn’t recognize that the charger is plugged in. I tried using a different extension cord, hoping that that was the issue, and even tried running AC power directly to the pigtail on the charger. No difference. Looking for some guidance here please.

Charger is a Zivan charger with the “selector” switch set to “C”. It has white stickers on it indicating that it has been upgraded with a 7 day and 14 day restart feature. I checked for blown fuses in the charger, and they are good.

Welcome jasykas,
It is difficult for us to direct where to look without knowing what car you have, and what charger you are using.

Thannks. I did make a new post 2002 E825

Whew. For a minute there with all your posts in different threads, I thought you had 3 carts with charger problems.

Sorry, I was told by monitor to repost a new thread as the threads I had posted to were 10 years old. I deleted one of the 3.