8888 display, and no movement

Looking for advice again, as always! =)
I’ve got an ‘02 E825 that I resurrected from the dead with new gel batteries and a new Ride-4-Fun charger. I typically keep it plugged in to charge, but left it unplugged for a week. Went to back it out of the garage, and got a display of 8888 when I turned the key on. Plugged in the charger, and let it sit for a few hours (charger initially put the charge level at 75%, then gradually climbed to 80%). I unplugged and turned the key on, and got the normal display. So far so good!. I then checked forward and reverse movement, about 2 feet either way, and all was fine. Plugged the charger back in to make sure everything was topped off, and waited a day. Charger says it is completed (CC displayed on charger), so I backed it out of the garage and about 100’. Switched to forward, and got the 8888 display again. Tried turning off the master switch, then turning on the key to fully discharge, then turning on the master again. Display shows mileage when master is turned on again, or when charger is disconnected. But turning on the key switch still results in the 8888 display. Did I just watch my controller fail? Or is this a symptom of a corroded or loose connection somewhere? This cart sat neglected for years, so it wouldn’t surprise me to have corrosion somewhere… Just don’t know where to start looking.

Any advice would be appreciated! Thanks


I am a Gem Tech and have reprogrammed the g2/3 controllers with the old school controller. You should only get the 8888 display when in programming mode. I have seen controllers display 255 which mean all the functions were reset to 255 probably due to a short, which was easily fixed by changing each function back to default settings. Since your issue has reoccurred and now stuck on 8888 I’m assuming your controller has failed and needs to be fixed or replaced. You could try to get it reprogrammed but the issue most likely will occur again.

Ok, after the old tried-and-true method of grabbing handfuls of wires and wiggling them around, I found that one of the wires going in to the 16-pin wide flat harness connection (right hand side under the dash, to the right of the charger. I think it was a blue wire almost to the middle of the plug) had a bad connection. The plastic plug actually glowed as the wire was wiggled. I guess I was lucky to find this now instead of on the side of the road in flames. I cut and soldered each of these wires to bypass the plug, and lo and behold, its ALIVE!!!

Oh the old wiggle method! Never Fails! That’s great to hear! That’s your 72v to 12v dc/dc converter not controller. Did the gem get that part recalled? Polaris has a L-11-05 service bulletin and will replace that part free. Is it a PWB (printed wiring board), a sealed potted board, or a metal black box with fins? If it’s a PWB then that needed to be replaced back in 05! Also that blue/white wire (it’s pin 9) is power to start switch (micro switch meant to stop the motor when the pedal is up) inside the accelerator foot pedal to the the orange yellow wire to your controller! That’s why it had the 8888 code. Thanks for updating