2012 Gem - Flashing turtle but everything working fine?

I prefer “comedic backup”

1 Like

Wanted to give an update on this: A couple months ago, I redid the wiring so now the positive lead from the charger goes directly to the +72V on the PSDM as noted above. The negative has always been connected to the negative on the controller. The charger won’t work now unless the 12V disconnect in in the “On” position, so that’s all set. However, the SOC on the dash still doesn’t work and the turtle is still flashing. Basically, other than the fact that I can’t charge unless the 12V switch is on, everything is exactly as it was before when the positive was hooked up directly to the batteries… When I re-did the positive to the +72V on the PSDM, I did go through and manually calibrate/set the SOC to full after charging (by using the trip switch/blinker method described on many posts here). Not sure what’s going on. As I mentioned before, the batteries charge fine, as they did before. But I am totally stumped here.

We should explore a few other areas and look for other creative wiring “adjustments”.

  1. When plugged in to charge does the dash display show a yellow charge icon and an animated battery/bar graph showing as if it is charging?

  2. When plugged in to charge does the key still operate and can you drive the car?

  3. After a charge cycle (steady green light visible on your charger display) and you reset your SOC(via your turn signal method) - Does the Turtle ever go out?

Thanks for the quick reply - (1) There is no charge display lit on the dash when plugged in. (2) I just checked and I still can drive the GEM when plugged in - but the charger definitely does not work unless the 12V switch is on. (3) The turtle does not go out, even after resetting the SOC. Here’s some additional info - the GEM is a 2012 where the “original” charger is part of the controller. When I bought this, I was told that the charger couldn’t be re-programmed for lead acid batteries and that I’d need a new charger, which I bought. Again, I’m a novice and did some research but when I did find the charger on the controller, it looked like it was integrated into it and I couldn’t remove it. I put in a new charger and it worked fine for the first year, except the SOC gauge. No turtle flashing. Last year when the batteries drained down (forgot to plug it in for a while), the GEM went into turtle mode. I was able to “limp” it back to my place, charge the batteries, and the batteries charged up but the flashing turtle never went away. Sorry this is such a pain to explain. I wish I knew more about this.

Ah! So the plot thickens!!
More Q’s (I am going somewhere with this-BTW)

  1. Do you know what charger was originally installed?
  • If you don’t know, can you supply a pic of it?
    Usually it is under the shelf the controller sits on. It might be tough to see, but get a pic of the labels that have the model no and barcode # printed on it.
  • Is it still in place?
  • Does it still work?
  1. What charger are you using now?

  2. What batteries are you running now?

(1). The original charger integrated to the controller is a Delta Q (labeled is "Delta QuiQ).
(2) The new charger I’m using is also a Delta Q. When I do charge the batteries, this charger works fine - lights on the charger go through each “step” until all batteries are charged.
(3). All 6 batteries are standard lead acid batteries that were brand new when I bought it a few years ago. For what it’s worth, they came from Advanced Auto parts. From the very beginning I questioned why the charger couldn’t be re-programmed. But was told since it was integrated into the controller, it couldn’t be. Since I use this at a seasonal park here in New Hampshire, I remove the batteries in the fall, check and top off the acid level in each cell, charge them fully and keep them on a float charger in my garage at home until spring.

Forgot to mention that the original charger is still in the GEM mounted on the controller. But hasn’t been plugged in since I installed the new charger.

This is not actually correct, the charger is just mounted under the controller

If the car will only charge when the key is “on” you might have the charger positive cable hooked to the wrong location, it sounds like you might have it connected after the contactor so it will only charge when the contactor is engaged.

As @AssyRequired a couple of pictures could go a long way here.
One of the charger
One of where the positive charge cable is connected

I am going down the path and betting this is all Interlock related.
It is still running through the old charger.

Ebko was told (or confused what he was told) the charger was integrated to the controller, but I’m thinking the original DQ charger is a DCI. If charger was removed, the DC converter would go with it. Car not go! This is not the first time people have been told the old DQ needed to be left in the car.

What is bothersome is that he was given bad info that the original DQ-DCI would not support Lead, and could not be reprogrammed for such. This I need to see.

Pics of the new charger would be good too. Was he sold another DCI? Or just another DQ?

In any case, I have a strong feeling the green wire(interlock) needs to be cycled for the turtle to go away and the SOC will also function properly again.

Makes sense if the old charger is still “in the loop” - 2012 car should definitely be DCI.
Still does not make sense why it would charge only with the key on tho.

Still does not make sense why it would charge only with the key on tho.

I don’t think he meant that. I think he was saying main switch (breaker) on. At least that is the way my brain translated it.

Ah, ok, that is not how I read it. You could be correct tho.

Unfortunately IO’m having problems trying to upload the picture of where I’ve hooked up the positive lead from my new charger. And yes, I did not hook up the green wire from the charger - instructions stated it was “optional” (which probably is true if I was replacing one that didn’t ago though the controller)

In any case, If the original charger is still FULLY wired up, It would be a simple matter to ferret out the original power cord and plug it in.

The display will change to charge animation and the turtle may/should go out.

Pics may not load if they are not the correct format. If straight from phone they may be not standard jpg.

OK - so I connected the old charger and the charging light icon and SOC is working - I’ve never seen this since I had the GEM. I guess the question now is whether there is a way to re-wire my current charger (Delta Q) so the display would work ?

New charger- sure, we can wire the interlock through it, but I’d rather check out your old charger first.

Now unplug it for a moment and turn on the key and see if your turtle went out.

Yes, the flashing turtle is gone - Thanks ! For the old charger, this is what I was told: It was set for AGM batteries. I questioned whether it could be re-programmed and was told it could not. Again, I bought this knowing (thinking) that I’d need a new charger with the lead acid batteries. Here’s what I’m guessing, and again, I’m a novice with GEM electronics. The first year I had it, other than the SOC and charge display not working, everything seemed OK. When I let the batteries go down too much and it went into turtle mode, it had to be reset with fully charged batteries which I have. At this point would much rather just re-wire my new charger properly and basically forget the old one

No worries. You found your way here. We can take care of you.
Know that your were most likely fed some wrong info. We can help you check your old charger. It may already have the lead profile programmed in (they usually do) and it just needs to switch over to it.

Not knowing what you were sold I am not sure your current charger will completely replace the original charger. I can’t even picture where another charger will even fit in the car.

I mounted the charger under the dash. I actually had a fair amount of room. The new charger is working fine. If there is a way to re-wire the current charger to make the charge and SOC display work properly, that would be great. But at least at this point, I know the batteries are charging and the turtle is gone.

It’s just a little redundant.

If your old charger is fine, you can remove your new one and someone here will probably buy it from you.