Rebuild Polaris GEM e2

I pulled out my Polaris GEM e2 to rebuild. I have completed my Polaris GEM eS with the help of everyone on this forum. This unit was purchased in “non-running” condition. It had the original Polaris batteries in it and sat for over a year. I charged each battery with my car charger. They would not hold a charge so I purchased 6 12V lead acid batteries. I get 75.6V from the total pack. Initially the charger was loose so I bolted it back in place. I don’t know why the previous owner tinkered with the charger. I tried to charge but I get a algorithm 4 so I tried to manually change to 3 for lead acid but I get a flashing red light. The display does not come on at all. I checked all the fuses and replaced a few. I still can’t set the charger. What is my next steps? Do I check the ignition switch next?

When in profile switching mode and it goes to red light that means you waited too long and it dropped out. You need to unplug the charger and wait for the red light to go fully out (and a few seconds more).

Then start over. Verify if you changed anything and go from there.

It is a very user hostile process that not everyone gets the first time(or sometimes EVER!!!). Sometimes you just need to walk away, take a breath and try again later.

Pro Tip: Whenever you are asking a question about a red flashing light it helps if you count the flashes between the pauses and note that flash code here.

That is no joke… Sometimes it’s one quick touch, sometimes its a full one second touch (touch and hold).
I broke down and bought a programmer it was so hard. I think I actually only accomplished changing profiles manually one time. I wish you better luck than I had. :slight_smile:

I read the manufacturer instructions on changing profiles and decided I wasn’t even going to bother with their inane tappy-tap-tap method, I just bought the programmer straight away.

Programmer gang member here too,

One time using The tap method was enough

Some, I included, have put together a 9vx2 tap box to change profiles.
Another member built an aruino to change profiles, similar to the method used in 2016 Gems.
click click click
I believe that programmed intervals work consistently. It could be a device to put DQ in program mode with a button to step through available profiles.

The red light is on pause then flashes twice.

For my 2015 eS model the tap method didn’t work so I purchased the programmer. I loaded the software on my laptop and hooked up the hardware. No communication. I talked with the Delta Q people. They provided the unique manual procedure for GEM only using the on/off MDS switch. It worked very well. I returned the programmer for a refund. That’s why I’m trying the manual method on the 2015 e2.

Are you saying you cannot get back into Programming mode?

When you first plug the charger in (from a cold start) is it still flash #4? THEN time out and go to a Red(2). ← This is normal.

It is difficult to tell if you made it in. There are slight changes in the display so you need to pay attention. If you keep getting the Red(2) then change up your timing on the switch flip.

I built one of those, but it was 9vx3 (I think you have to like 24v min to trigger) - it worked better than other methods that is for sure. But the programmer is by far the easiest - IMO

I’ve found that you have to disconnect the psdm & gem electronics from the charger or it will somehow prevent communication between charger and programmer. I usually only unhook the positive lead.

Unhook the positive lead to the psdm? Are you saying this will help me with the manual method of changing the algorithm or using the programmer method?

That instruction was for the software method.
He was suggesting that it was possible something in the PSDM was killing the link.

When I do the “tap” method I just use the Main Batt switch on the bottom of the fuse panel.

This condition had me stumped at first. Something about the design of the PSDM stops the QuikQ communication over charge power signal.

First encounter with this condition was when I was setting up eL BlueBallz for testing an early release 8kW / 10K rpm AC motor that I never did install due to the fucking pandemic… I ended up calling @MikeKC (while he was on vacation which was unbeknownst to me …) about this communications / detection failure because I couldn’t get the QuikQ to talk to the charger in my '10 even though I had already tested the communications and verified that the QQ was was able to talk to a spare charger I had on the shelf. Couldn’t figure it out, no reason the QQ and the DQ shouldn’t talk, with the PSDM in the circuit, even DQ tech support didn’t have any advice, but yet they weren’t… I felt like a pirate with a ships wheel on my cock…

Arrrr, It’s drivin’ me nuts…

… and about ye eye patch… arrgh, a pigeon crapped in my eye and it was me first day with the hook…

Thanks for the clarification! I have been using the MDS as well per the instructions. I must have tried this method 50 ties yesterday with no success. I tried different timing but not working. I’ll try again today.

Ok, I need to try something different. The manual method worked on my eS model when the program failed (I returned the program hardware & software). I can buy a used charger for $200 + freight & try the manual method or purchase a program software/hardware again and try or send my charger to be serviced? Are there other options? If I can’t charge my batteries I’m dead in the water.

So, you’re asking us if you should go with one of the following options:

  1. buy a used charger, hope it works and use the tappy-tap-tap programming method.
  2. buy the programmer back and use it on the existing charger that you have.

The answer is: YES.

Option 3 which I have mixed feelings on for your GEM is to shoot it, light it on fire, crush it with a bulldozer and fire the pieces into a decaying orbit around the sun.

Still torn on recommending the latter or not.

Of course! Communication signal is from black to red charger leads.
Nothing can be connected to charger output. Same with the tap method. Even the dci chargers can be difficult as the dc-dc input caps are connected to charger output.
Best way for tap method is with nothing connected to charger output. I’m amazed seeing sucess using the main disconnect method. Not only is it stressful to the poor little power switch but any capacitive load throws the timing way off.
Polaris uses automated tap tap comunication on the new gems succesfully, by breaking the connection at the red charger output.
Using an in-line relay contact.
Programmed timing makes it work every time.