Only Hitting 20MPH!

So I’m a bit confused and hoping someone out there can help me. I’ve got a D2 controller that I have reprogrammed with the following: value 7 (69) and value 20 (40). I have brand new D&D motor and yet I can only hit a top speed of 20MPH, measured by GPS and Speedo. What could be causing this problem? Prior to the reprogram and motor swap (original 4hp) I was only able to achieve 17MPH but the motor was overheating within 10-15 mins so I just assumed the motor was garbage and need a new one.

Sounds like it might be in turf mode. What does it do when the key is in turf mode? Also check battery pack voltage at controller while driving 20 mph (2 big wires drivers side)

Turf mode tops out at 14/15 mph. I’ll check the voltage this weekend. I also noticed the right rear wheel is dragging significantly, difficult to turn by hand (when in the air). Could it just be a broken spring or warped drum?

I also noticed the right rear wheel is dragging significantly,

This would have quite a bit to do with it. Check to make sure your park brake is releasing completely?

1 Like

Checked again and the wheel drag I fixed, but still not getting over 20. Hooked up volt meter on the controller inputs while running at 20 and I can see 71.5v at 20. Battery voltage to start was 75.8.

That will slow you down for sure. All the wheels should spin easily. The slides on the brake shoes and or the wheel cylinder are probably seized.

The next thing I blame is your battery pack, But running your numbers I talked myself out of it.
How are all the connections? When you ran your V check did youput your meter on the cables or the controller tabs? How are the cables going down to the motor? If resistance(bad connection/crimp) then it will feel hit after a high speed run.

To go faster takes a bunch more amps.

Assuming all batteries are perfectly balanced (running your numbers)
75.8 is 12.63 per battery at rest. That looks good.
Under load
71.5 or 11.9v which isn’t bad for a load either.

12v battery SOC%

Post a screen shot of ALL your controller numbers. Maybe I can spot something else that may be limiting your speed.

What is in-
#4 - Max Arm Curr?
#8 - Max Field Curr?

I’m connected at the tabs of the controller using alligator clips.

Attached are the current configuration settings of the controller.

Appreciate the help!

Fix that wheel dragging. You should take all the brakes apart and free up the sliders on the brake shoes. If they’re not seized, I’ll be amazed.
#1 factory setting is 18
#7 you can lower more since you have a D&D motor. You should be safe at 60 but this is not your problem.

Do you or anyone else know a direct replacement for the wheel cylinder other than Nev?

Dorman W37347. Sometimes you have to do a little grinding.

1 Like

Been a while since I’ve had a set of GEM brakes apart, and can’t say for certain without measuring, but hat looks like it might fit some GEM rear drums also.

Hey David, I’ve fixed the wheel drag but still no increase in speed. The cart has serious torque but just top’s out at 18-22 mph depending on incline.

Did you change setting #1 to 18?

CRAP I missed that one, I will change that in the next few days and post back. Thanks!

So, I updated value 1 from 68 to 18 and still topping out at 19-20 mph. :frowning:

I checked my settings and 1 is set to 20, 3 is set to 15, 7 is set to 60, and 20 is set to 35. My Think goes 35, although I rarely go over 22mph.