G-Wiz AC SOC Doesn't drop (power meter)

Hi everyone,

It seems that i have some sort of a problem with the SOC meter on my dash.

When i charge the vehicle the SOC goes up as normal and when the charge finishes then it shows 100% but as i drive the gauge doesn’t go down. I tried disconnecting and reconnecting the EMS and the first time it reads the SOC fine and shows the battery charge but when i charge it and drive it again then the meter just stays at 100% again.

Any info or wiring i perhaps should check would really be appreciated.

It is as if it doesn’t read the discharge although when i connect the EMS manager the voltages show up fine and everything else.

Welcome to our group. Your problem is new to me. Hopefully other members can give you some help. What year is your Wiz? Are your batteries Gel?


Thank you.

My batteries are normal Trojan batteries. The problem started after i cleaned the inside of the electronics bay. I thought that i might of bumped a wire but everything seems to work fine. I rechecked all connections and the EMS charges fine. Don’t know what year exactly. Its an AC G-Wiz. Probably 2006

Should i really be changing the EMS for this?

Don’t think so at this point in time… Suggest you get a can of ELECTRONIC CLEANER and unplug and spray all connectors.

A work around is to purchase a volt meter off Ebay for about $10 and make your self a state of charge note. You will then know where your at down to the tenth of a volt.

I have one on my machine. Also shows Amps


I really would rather use the existing electronics. If i wanted i could redo the whole thing but since it already exists i like the idea of fixing the problem rather than going around it.

I understand. Hopefully someone will chime in with a better solution


A little info here. Haven’t looked thru it yet.

Sorry for asking, but::o

First, are you 100% sure it isn’t dropping? There may some integration in the soc circuit that averages readings with time.

Like fuel gauge reading low for a while after filling.

GoinGreen G-wiz Owner’s Manual (Page 7 of 100)

I charge the car. The reading goes to 100%. I drive 20 miles. The reading is still 100%. I read the soc in ems manager and it says 100%. I reset the ems and the reading shows normal at 35% i charge it again and the same thing happens… the reading doesnt go down.

Any chance that someone may have the HEX firmware file for the EMS so i can try and reflash it? I have all the equipment here for the PIC microcontrollers so can do the job no problem.

If anyone is interested, i fixed the problem.

It was a simple matter of a broken wire connection.

Since the Charge goes up when the vehicle is charging and in general works fine as well as everything else, corrupt EMS software is out of the question since if it was corrupt it would most likely not run at all and not connect to the EMS manager since you need to really try and corrupt the internal EEPROM on a PIC microcontroller (the controller which runs the EMS).

Since it only doesn’t drop then the problem was in the power (Ah) measurement while driving and in general while draining the battery. The EMS measures the battery through a simple 2 wire connection to the negative pole with a mechanical resistance in between. You shall find this if you look just after the contactor. There will be 2 thin wires connected (Red and White) with screws to the main power pole. These two wires go into the main EMS connector (CN64) and are the only 2 thin wires. The third is just the shielding and doesn’t go anywhere although connects to what i assume is the GND on the connector.

Visually both wires were connected firmly to the connector but when testing for continuity there was none. A simple way to test this would be to connect one terminal to the Red and one to the While cables. Normally there should be continuity. Turned out that the wire was held only by the rubber sleeve and there was a broken connection. Re soldered the wires and everything works fine now.

It would be pointless to check for a broken connection inside the wire since it is well protected by the metal shield and is most likely to brake at the terminals if someone is going to do this test. These are the only 2 thin wires on the connector so they are likely to brake if you pull the connector too hard when disconnecting.

I personally recommend NEVER to use crimp connections and ALWAYS solder the wires. This problem could also give false or erratic readings on the Power meter in the vehicle if the connection comes and goes so it is reasonable to check this first if you have a similar problem.

Hope this helps someone else if the same problem occurs.

1 Like

Thanks for coming back to us with the fix. Some people don’t.

Hi Thanks for the info, i will check that now on mine. I have a slightly different problem, I have an AC car (g-wiz i) and all seems to work ok and i get about 26 miles from the car which is ok as the batteries are 5 years old. However when i press the throttle, the SOC gauge drops massively under load in real time and returns back to the original position as soon as i let off. i can play yo-yo with the gauge as i play yo-yo with the pedal, i dont think this is normal even for worn batteries. I compare this to my other ( g-wiz i) and it does not do this,it just slowly drops as the battery is used. I could live with this but if the gauge goes into the red the car seems to go slow from that point onwards even though it pops back well into the green once i lift the throttle. any ideas? Thanks

Check all connections for bright and tight. Check batteries for a bad cell.

Hi Fgcity

Many thanks for posting the solution to your problem - I can guarantee that others will have the same issue in the future. This is most helpful of you.



Hi Thanks for your reply, i have checked all the connections i can and all seem to be good. I have recently replaced on cell that was bad and the range is back to a decent amount, its only after i replaced this cell that the problem came with the soc meter, perhaps i need time for the ems to get its head round the new battery?

Hi, I was wondering if you solved the issue.
I have a Gwiz and I the gauge indicates an always full battery, dropping only when I press on the accellerator.

Hi, sorry i didn’t. sadly i sold the car cheap because of this, did you fix yours?