2006 E4 not moving/ display flashing

I have a 2006 GEM E4 that I bought about a couple of months ago. I was told it needed new batteries, so that has been solved and I have plenty of juice at the PSDM (74.5 DCV). Originally, when I powered on, everything worked, including the display with no error codes, and all accessories worked, but the car wouldn’t go forward or backward when the accelerator was pressed. The contactor plunged in (I have removed dash so I can not only hear it but see it). There were no error codes on the dash, just no movement. I have the front end jacked up so wheels are free to turn without resistance.
I started following the GEM service manual electrical trouble shooting guide and found that my main contactor was bad. I replaced it. Nothing changed except to go from bad to worse…

Troubleshooting the accelerator pedal assembly led me to believe that it was faulty so I replaced it with a new one from R4F. ( I had gotten an error code 11 when the pedal was pressed as well) Installing it changed nothing, still no movement and now my display, which had been normal shows the wrench, turtle, and temp icons flashing with flashing boxes around the drive modes. The contactor no longer clicks when I power up and turn on the key.

I sent the controller to R4F for testing to see if it was at fault. 3 weeks later (and $150 more) I was sent a refurbished controller and told that there was no issue with my controller.

I have gone through the trouble shooting guide with my test meter without any success so far. I have seen numerous other posts here where owners posted similar issues with the display flashing all the icons yet no one seems to have posted an answer to how it was resolved. Any suggestions would be appreciated! Summary below for reference:

Fresh charged batteries, 74.5 volts at PSDM
Display shows all icons flashing when keyed on
All 12V accessories working
Contactor does not click when keyed on and accelerator pressed
**Buzzer works when main power switch turned on, pull up E-brake & it stops. **
All fuses check out ok
All connections checked and re-checked at controller, display, PSDM, motor tach and temp sensor. Continuity checked on all wires in the harness to PSDM

With the help of this site and AssyRequired, I was able to resolve the problem with the display flashing all of the icons. I had to remove the 23 pin connector from the motor controller and remove the red front locking cover that covers the female connectors connected to the wires. Then, using a hobby pin-probe I pushed the pins on the side of all connectors (3 each) inwards to effectively tighten each connection. I had apparently reamed them out so to speak with my multi-test meter probes while doing troubleshooting.
One problem solved and now on to the original issue…car not moving! I’m getting a code 81 when I press the accelerator which I see means “no speed sensor signal detected”. I’ll troubleshoot that tomorrow since the temp here is too much to stand right now!
I hope this helps someone else who might have had the same frustrating issues with the flashing icons on the display!

boy, it sounds like things are getting worst and not better. When you started it sounded like everything worked except the motor was not turning. ie contactor engaging, key on/off working, e-brake switch working, no codes on the display, batteries had power/voltage( but low @ only 12.4Vea ) and 12V accessories were working.

At that point I was going to say to put a DMM on the 12V to make sure it’s ~13V then to watch the battery voltage when you pressed the throttle pedal. After that I was going to say make sure there was B+ and B- battery voltage at the top of the controller followed by checking B- to F1 and and B- to F2 when you pressed the accelerator pedals. The motor field windings should be getting voltage when the throttle is pressed.

Now, more stuff seems to be no longer functioning so it’s now a job getting back to where you started.

BTW, fully charged lead batteries should have ~13.8V on them when the charger is on and they are at the last(yellow) stage of charge. An hour after the charger stops, the battery voltages should be ~12.7V each for good healthy batteries. 12.4V is probably 50% charged and 12.0-12.2 is empty and you should immediately charge them.

Updated yesterday with regard to flashing display, 23 pin connector on the controller was the issue…I had made the female connections loose with my test meter probes. I removed the red locking cap on the plug and used a pointed tool to press the 3 springs back in on each connection to “snug” them back up. Now at least im back to where I started with a working display.
Pressing on the acceleator, I get code 81, no motor speed sensor signal detected. I’m going to troubleshoot that in just a few mins. I’ll go through the steps but i think its actually the motor.

As for the batteries, I haven’t charged in a week or 2, so 12.4 at each battery is fine for testing purposes, I’ll get it back to full charge later today!

1 Like

I saw that. I agree and am leading you to the motor also.
It is looking alot like stuck brushes.

What is the history of this car?
How long have you had it?
Was it running when you got it?
Has it been sitting for a while?
What motor is it?

Just remember that lead batteries need to be kept at full charge to optimize capacity. If they stay at any depleted level for very long they start to deposit sulfates on the plates which don’t come back off. Better to fully charge, experiment and test things then throw the master disconnect until your next time. Lithium batteries have the opposite characteristic in that they don’t like sitting “Fully” charged so instead of charging to 4.2V we often only take them to 4.1 or 4.0v/cell charging but they are happy at anything below that just sitting there as long as it’s above 3.0v/cell.

I went out a few minutes ago and checked the speed sensor ,12v at red and black and continuity on green data line back to the controller pin 14. I pulled the sensor cap off and looked at it but nothing to see (photo). Rotated the tire while cap off and could see motor spindle turning. Buttoned it back up, turned on power and key switch on, dropped ebrake, stepped on accelerator pedal and YES, ITS ALIVE. Front end was on jack stands, put the drive modes through the paces and it worked! I took her off the stands and drove it around the back yard for a couple of minutes before having to leave to run errands. So thankful for your help and hopefully she’ll run good this afternoon on a test drive
I’ll keep you posted! :+1::beer::beer:

1 Like

Hopefully you remembered to plug it in to charge before you left.

I’m still trickle charging individually since I now have lead acid batteries instead of the gels that were in it origi ally. I haven’t changed the algorithm on the charger to my current setup so doing the trickle until I change it.
Test drive was good except I only got 18-19 mph. No error codes or other issues. When I had it on jack stands, i got 25 mph so I know that with no load the motor will do that…maybe just an issue with needing to juice up those batteries a bit more!

i got 25 mph so I know that with no load the motor will do that

Well maybe yes, maybe no.
It all depends on what you installed for batteries. Charge them up and balance them properly and see how it goes.

Yes- change that charge profile and stop messing around!!

Are you a moderator? I’m Jim (pronounced Gem lol). What is your name?

That’s not very turbo of you…

Check for dragging rear brake shoes. They are notorious for hanging up if not well maintained. Even a slight drag on one wheel could cost you that 6 mph.

Thanks for the suggestion, I’m charging now so I’ll check that out when done! :beers:

Jack up the rear and how free are the wheels spinning?

Yep, thats where i was going to start hopefully later today! Thanks for the tip!

Sorry for the delay, life got in the way of this little project car lol…
Rear wheels turn freely, but the front end was WAY out of alignment. Corrected the “toe out” misalignment and now I’m getting a solid 25 mph in my neighborhood. Wish it was more but ehhhh, speed limit is only 25. Thanks to everybody here in this forum for suggestions and help!!

With a magic magnet your 06 should easily be able to clock in the low 30s, even with the lead in it. Get in touch with @Inwo to get one. Install takes like 30 seconds, it just plugs into the motor tach signal wires.

Thanks, im familiar with that product and will message him soon! Thanks!