Completely Stuck on 2014 e4

New to GEM and new here. I have the flashing wrench, temp, turtle and drive mode squares. I have tried forums and service manuals but can’t figure it out. Everything seems to work except being able to choose a drive mode and go. I also did the check on my charger and get that I am running #14 with Trojan flooded batteries. The tap method is not working for changing it. I’m not sure what my next step should be. Any help or suggestion would be appreciated. Thanks!

When the dash flashes like this, it means the Dash has lost serial comms with the controller. It could mean a bad connection, or something is wrong with your controller.

First and easiest to check is Fuse 13. That is the round thing on the bottom right side of your fuse block.

Thank you for the quick reply. I removed fuse 13, tested it for continuity and got a beep. It has a white barrel so no visual confirmation. Can I test its connection to the rest of the circuit?

I have done some random testing and I can’t find anything wrong, although I am no expert. 77V at controller Pin 1 and 2 and everywhere else its supposed to be. accessories seem to work, parking brake and reverse beeping seems normal. relays test how i would expect.

Its a long story how I got to this point but ill elaborate if that is helpful.

OK. then check the main harness plug up at the controller. This is known as the 23p. Locate the spring retainer/catch. The vertical tab needs to be pulled out to the horizontal hoop a bit and the plug will wiggle out.

Inspect for foreign matter, water, or corrosion. Put it back in with a little wiggle/skritch and push until it clicks.

Try KeyON again

everything looked clean and same flashing with key back on. tested pin 1 and 2 of this connector to controller - earlier based on troubleshooting guide and got 77V at each.

How much background is available about this car?
Was it running when you got it?

I got it a couple of months ago and it has run fine up until this weekend. The sellers said they had put a new motor in it recently. It has a ride-4-fun speed calibration thing on it near the motor. I don’t know anything about this motor vs the old, but I guess this mod by ride-4-fun is not uncommon? They claimed they could now get the thing up to 40mph, but I haven’t been able to get it to even 20. My neighborhood has hills and I don’t want to go fast anyway, but something doesn’t seem right there. They also installed an aftermarket radio with enough folded and rubber banded speaker and power cable to reach the rear of a carnival cruise ship. One or both of these things were drawing power when the car was off. There were also some minor irritations that I knew I would eventually have to find time to deal with like the horn not working. The thing that made me take the dash pieces off and start tinkering was the ground wire coming loose on the radio coupled with a key switch that was on its way out. I replaced the key switch with a push button and I have been driving it like that with wiring exposed for a few weeks while I study the wiring vs the manual and order some stuff from amazon to try out. It has been garage kept during this time.

Now we get to the part where I may have gotten cocky and flew a little close to the sun…The reverse beep is insanely loud. It is just not fair to my neighbors if I want this thing in another spot in the driveway early in the morning. My kids also use this thing so I would not just disable any safety feature, but I thought it might be possible to put the beep on a switch. Once I figured out where the buzzer was inside the PSDM I got scared of what cutting one of the wires might do overall, so I decided just to give myself access to it for now. I cut the knob part of the black plastic cover on the top of the PSDM off and popped the clear plastic cover off the buzzer so that its latch on one side was broke and I could just pull it on and off and it will stay on if left alone. I did not modify anything electrically inside the PSDM, but I did remove it from the vehicle and unscrew the circuit board from the plastic cover. When I put everything back together I turned it on and everything was normal. I put it in all drive modes and it worked perfectly normal. That would be the last time though. I went back to working on the ignition situation and the next time I turned it on I got the flash. I have removed everything I added for the ignition now. I have spade terminals on the red/white and white wires on the steering column to connect for a key. As I mentioned before I also read about the charger algorithm and it reads 14 when I have trojan flooded batteries. I can’t get the tap method to work to change it to 13.

Thank you so much for even taking the time to read this. I really appreciate it.

OK, Much going on here. I’ll go back and see if I can ferret out the major components of interest. Here is the next point to check one point of concern.

The serial path for the display actually goes through the PSDM. It could be a bad connection there too.
From the controller it goes in on connector J5 and comes out J3.
Check both of these connectors. Give them both s hit of contact cleaner spray and work them in/out a couple times befor the final clock.

Your beeper delete hack.
Clarify: → When you went after the reverse beeper,
Did you cut the plastic to the beeper module or the plastic case to the PSDM just to get to the beeper? Can you post a pic of this?
My concern is that you did not go after the correct component. It sounds like you were attacking the KeyON relay and NOT the beeper at all. The actual beeper is about mid board and off to the right side.

The connectors look fine to me and seem to set cleanly.

I guess that could be a relay. It has a wiring diagram on the plastic, but I couldnt really make any sense of it. It sure sounds like thats where the beep comes from. Would just messing with the plastic around it cause an issue? I was going to use two sided tape or something to fix the black cover back on that knob. I am attempting to post a pic here. first try.

I guess I should add that I found that after I got the flashing error the first time I had to replace one of the 1A fuses to the display. I can’t recall if it was 4 or 9 unfortunately, but I think 9.

Yeah, That is the Key Relay. (I refuse to call it the IGN relay because there is no ignition in a EV. It is not an action one desires at all.)

Re: Flashing Display - I don’t think your beeper hack is the issue, but it would be a good idea to spend some time later and button it back up.Later I will show you the different ways to deal with that beeper. I don’t want to get distracted from the primary issue of the car not running.

Verify-> Is the car not running? Have you tried pressing the pedal and listening for the loud “clack” of the Main Relay? (remember to drop the hand brake). Note: The Display is not needed for the car to run, but it is your window to WHY it is not running.

How far have you worked your way up into the Dash Pod? You mentioned that you were working with the replacing the key switch. It is possible that you partially pulled one of the connectors out of the back of the display. ← Check this

I also find it interesting that you had to replace the display fuse recently (F5 or F9). What do you think the cause of this was?

You are awesome for this. That figures about the relay/not buzzer, glad I didn’t mess with it anymore. Could it have gone bad outside of this?

Nothing I do makes the solenoid clack short of jumpering 72V right to it. The contactor has 77V to batt-, but only like 46V to the frame. It doesn’t clack when i connect the key circuit or hit the accelerator. The positive cable right from the battery pack lands on the main contactor, so I suspected there might be an issue here, but I am not sure how to confirm.

I checked the two connectors on the back of the display and everything looks normal. The display seems to be fully functional…I think. All the lights seem to work.

What might be another stupid plan was to replace the keyed switch with two push button switches. One in the former key switch position for typical operation around the house, and another kind of hidden inside the glove compartment that could be turned off and locked with a key if necessary, kind of like a second main disconnect that a potential thief or vandal wouldn’t know about. I was trying to hook this mess up…the switches both had led lights as well, when that fuse blew I believe.

I imagine it is becoming clear I am no mechanic or electrician. I can make out enough from the service manual drawings to make myself think I can do this stuff. I also just don’t know of anyone to work on the thing. If anyone here knows of someone within 100mi of Chattanooga, TN I could probably save myself alot of headache. Again, can’t thank you enough for your help.

Key relay - Could it have gone bad outside of this?

The fact that display lights up when you KeyON tells me the Key relay is probably OK and doing it’s job. There are other hints also showing me this.

Nothing I do makes the solenoid clack short of jumpering 72V right to it.

Many make this assumption.
Note to your future self: Be very careful about poking about in the systems without knowing exactly how they work. It is really easy to mess up expensive and difficult to find components this way.

That relay is one of the last things to activate before the car will go. Closing it prematurely(at the wrong time) can damage the output transistors in the controller.

Your observation of seeing B+ on one leg of the coil is normal and expected. It is actually the downstream leg that goes to the controller and when the controller decides it is time to close the contact it brings the other leg to B-.

The reason I asked about the clack of the contactor is that I was trying to blindly determine the state of the controller. By going through the normal steps to run the car it sounds like the controller is NOT happy and possibly not even booting up. The only thing you did not verify is that you dropped the handbrake in your steps. It is easy to forget.

The contactor has 77V to batt-, but only like 46V to the frame.

This is normal. Your second V reading is a fake voltage as it is probably backfeeding through another component when you are using frame for reference to measure anything Pack related. The Pack is actually isolated from the chassis/frame by design. 12V dc Acc Neg is found on frame and used for the lights, horn, and wiper.

With all of these points checked and verified, and still not getting the display to see the controller, I am leaning towards the conclusion that your controller needs to be sent in and checked. The best place to do this would be FSIP (Flight systems) in Florida.

Well that’s no fun. Is there anything else I should test to try to verify this? What do you think could have caused it? It would had to have been around the same time as that fuse blowing? The testing of the relay was after I was already having the issue. I think that is what you are saying I should not do is jumper to that to test it?

I did lower the handbrake when I tested the accelerator.

Can I buy a replacement controller?

@AssyRequired pin 1, 2, 23 making good contact to controller pins? The old stretched contact ploy.
Same at psdm. Have we ever had issues between controller and dash?

I will look at that pin closer and post a pic


Get Smart, Dragnet? Am I on the right track?

Here are the 23p connector pics. I see no reason there wouldnt be good contact.

I am on the fence whether I should attempt to walk you through this.
It all depends on whether you have been direct probing this connector.
(checking the wiring with your meter probes)

It sorta sounds like you might have? If so, did you run through them all? Specifically Pin23? I think you tried P1 and 2.

I believe just pin 1 and 2 were part of the guide. 23 should have the same voltage? It sounds like you are saying I should not be testing with a meter at all?