2005 GEM - discharge after 2-5 minutes of running

I have a 2005 GEM. I replaced all my batteries with new AGM, then I got a new charger from ride4fun. Batteries charge up nicely, all shows good. I drive for 2-5 minutes and the display flickers (no error code) and then the car dies. If I have the car “on” and the brake is off, the beep sounds, but otherwise no sign of life.

When this happens I check the charger and the charger is reading 15-20%. Then it charges up and I can repeat the whole cycle.

It seems to me like I am running out of battery life? Ride4Fun thinks its a controller issue - just wondering if I should check anything else before pulling the controller.


does yoy battery meter on the dash show any bars??

Battery shows full charge and supercharger shows full charge. Then when it dies the display is still showing full. Supercharger shows 15-20 percent

RFf is saying it may be because my batteries are too new and not enough charging cycles to hold enough amps. Or a bad battery. Any thoughts?

Ok. So full charge, all batteries measured 12.6

Left for two hours, all batteries at 12.6

Ran for 1 min, screen flickered, then car died.

Still meaures 72v at main, though charger started at 30% and stepped to 80 % quickly and is now charging

Any help greatly appreciated.

Ok here is an easy way to load test the batteries. …fully charge the battery’s…take a digital meter…set it to 12 volts or a setting just above 12 volts (mine will only go down to 20 volts).clip one lead on the + and the other on the -…see what the battery’s volts are…then with the volt meter still hooked up turn the key on…hold the brake with your foot. And then start giving it gas (this is placing a load on the system)…hold it to the floor for about 3 to 5 seconds…watch the voltage drop and see how low it goes…anything below 11 volts the battery is on its last leg…I had one that had 12.3 volts untill I hit the gas and it went to 2.8 volts…probly not the best way to test but I wasnt going to pull all the batteries to have them tested…it worked … but I have replaced the whole pack now if one is bad it not good to replace one new with several old battery’s. …I have a video of the test I will post…

Ok. Thanks. I will try that. These are all brand new batteries. At this point I am hoping one is bad so I have a reason for this.

Try the test I gave ya on all batterys …I was suprised on how much they droppex but then came back up …it will tell ya whats going on and testing all 6 batterys will only take about 20 min. .I will poat a vid in just a few …trying to get it up loaded now

lets try this

voltagedrop1_zps972a33af.mp4 Video by nosgsxr | Photobucket

voltagedrop2_zps9d6bf3d5.mp4 Video by nosgsxr | Photobucket

let me know if it worked…it does for me but…

Ok. Replaced the controller and then it ran for awhile. Then quit just like before. Restarted and ran again, now when I put the key in he dash display flickers.

Hmmm …did u try testing the batteries?

Nice ride Nosgsxr!


Intermittantly, the blinking of these 6 items stops and then MPH, odometer, and green bars all display nomally again, and with a correctly updating odometer reading

[quote=ARandall;16393]Nice ride Nosgsxr!


Thanks I have spent just about all I can spend on it…still wanting the 8.5 hp motor…thanks again