2000 Gem -04 and -11 issue

I have a 2000 or 2001 Gem 4 seater with brand new blue 7.5 hp Ride4Fun motor and new AGM 31 maint-free batteries. I am assuming it has an upgraded controller(prolly through Ride4Fun) since it is real fast. It was running great. Now I am having an issue with the codes -11(throttle pedal checks out ok and limit switch is ok) and -04(e brake is working and limit switch is mounted correctly). So basically I can’t get it to not say -04 and it sometimes also gives me a -11 code. When I get it rolling and then try driving it then it will “wake up” and let me drive. But if I slow down to almost a stop it will try shutting me down again and flag -04 again. It seems weird that it will go and not flash the -04 and -11 codes if it is rolling. Basically I need to push start it or it’s dead. Anybody have issues like this. I have gotten it to go from a dead stop after sitting for a few min and waiting for the dash screen to clear. Does anybody have any insight? Maybe water from drinks in cup holders got into something below and it’s shorting? It’s been sitting dry for a while. Is it a sensor on the motor? A loose connection that I’m missing?

Sounds like your parking brake switch is faulty to me. Have you tried removing the boot and reaching in to push the switch manually? If not, I’d try that first then I would ohm out the switch to see if its opening and closing as its supposed to (can’t remember if its NO or NC but it should switch either way). If your foot is on the gas and the car senses the parking brake being turned off, it will throw -11 so I’d lay odds that is a symptom and not causal. Focus on -04 as that’s likely where your problem starts. Verify the switch is absolutely good and then its a matter of chasing the wiring to the controller. Doubtful that its your controller but anything is possible.

Thanks for the reply I hear ya. I have the boot off. I am monkeying with the switch. It doesn’t make a difference. Why would it let me drive and ignore the parking brake switch (if it’s faulty)? If I push the cart down the rd the -04 with kinda flicker on and off and then go away as I press the pedal. When the cart starts rolling I can press the accelerator and go 40mph all day!? I’ll replace the switch but I’m thinking there’s more to it and maybe someone on here knows.

I don’t know this to be true but my suspicion is that once the car is moving that it ignores the parking brake interlock. I could go out and test it on mine to see but I’m not able to right now. If you can reach the wires going to your brake switch, disconnect them and see if the car turns on. If not, short them together and check. If neither works, I would be chasing the wires going to the controller. It could be your controller, but my gut is telling me its not. I’ll try to check on my car to see if it shuts off when driving and I pull the brake lever but not sure when I’ll get a chance to do it.

Ok, so I went out and tested on mine. If I’m driving and pull the parking brake I get an -04 and if I release it without taking foot off of throttle, I get the -11 as I would expect. I’m not sure why you don’t get error if you push start your car but I would be looking at all of the connectors for a bad connection. It sounds more like a bad connection or ground (these don’t use a common chassis ground) than it does a defective controller. I could be wrong but I’d be betting on an input to the controller and not the controller that is the problem. Check your wiring very thoroughly.

1 Like

Also, my headlights were intermittent and wouldn’t turn on until I started driving a little ways. But now they won’t turn on. Tail lights come on as soon as the switch is turned on… but no headlights now. The two red turn signal lights on the dash/steering column light up and I don’t think they did before unless I used the turn signal. Mystery. Weird.

I’d start looking at your 12V DC to DC convertor. I’d start by putting a voltmeter on it and see if its close to 12V DC and that it holds steady and is not fluctuating.

Mr. Vern, I think you are onto something here. This sounds plausible. I’ll try to take it apart and see if there are any other fuses I can check. I’m thinking it has to be something like this and/or water had gotten into something and since the under dash areas are not very weather resistant.

I attached some photos. I tore the dash apart. It has an onboard Surepower model 71030i converter. There’s no fuse on the unit itself. I checked all connections and everything seems ok. Looks like a spendy unit($330 on Amazon). I don’t have a voltage reader here at the campsite. I’d really like to get this thing fixed for our 10day stay next week. Frustrating. But it’s the game we play. Uploading: 0AE5D082-FA48-4BAE-8C26-00581663779D.jpeg… Uploading: 1FE67F94-8A33-4B05-9A15-A11A3E097F83.jpeg… Uploading: BBC0C6CE-9555-4921-B169-A279685104A0.jpeg…

If it turns out to be bad, @Inwo is the guy to talk to. He knows a lot about the various options. If I were needing one, I’d probably put the money toward a programmable charger with one included because when you eventually go to lithium, you’re going to want one. Check with Dave though because he knows all the different configs and options.
BTW - your image didn’t post, it just says its uploading as if it never completed that process.

image image image

I installed a new DC converter. I have control of my lights and blinkers now! Unfortunately I cannot get around my -04 msg. I have tried jumping the wires etc but cannot get rid of the -04 msg. Cannot drive it. I’m here at the campground for 10 days with no golf cart!!!
:weary::sob: I dont have a replacement switch. I’m looking for a “bush fix” tip

If you’re talking about bypassing the parking brake switch, that should be easy. Disconnect the 2 wires and see if the error goes away. If not, then the switch is NO as I would suspect. ALl you have to do then is take a paper clip and put it into the 2 terminal lugs you removed from the switch, black tape them and it should be bypassed. This all assumes the switch is the cause of your problem. If that doesn’t fix it, we’ll have to break out the wiring diagram and jumper around it right at the connector going into the controller - this will eliminate the wiring as the cause. If it still doesn’t work then you may actually have a controller failure but I just can’t believe that’s the case.

The connector by the left tip of the frame where the hood cable plugs in is notorious for failing. Check it out.

Thanks for the replies! I took my multimeter out yesterday and “went to town”. I finally learned how to use that thing. Awesome. I found many glitchy connections in this harness(pic attached). Also, I found some wires that were brittle and in need of replacement. My headlights stopped working again and the two red lights(turn light indicators) on my steering column stay on when I turn on the headlight switch. I think I will snip all those wires off of the harness, throw it away, and connect them Directly. That should eliminate all of the issues.

I probably did not need a new DC converter but it is what it is. Moving on.