Slow with Temp Light

I am working on a 2005 E4 with the Blue 7.5 Hp Ride for Fun motor. The Car does not accelerate as expected. Batteries are ok. Car tops out eventually at 21 Mph (GPS speed)

The temperature light is lit on the dashboard, It is under the Brake warning light. It is yellow with a circle around a vertical line with small horizontal lines from the vertical line (as in graduations on a thermometer)
No codes! The temperature light is always on, as soon as key on.

The temperature probe wires are tied together near the motor. I verified that +72V is going into the controller at pin 21. (signaling Not over temp) Disconnecting the wire leaving pin 21 floating does not change the performance of the car, not does the temp light go off.

The controller is a T4 (last digits in model number) Oddly is says “Re manufactured Motor controller” Another label says “Older vehicles without a brake switch must connect pin 13 of the main 23 pin plug to battery negative” And pin 13 is connected to 72v Minus.

Brakes were just replaced. All 4 wheels spin freely.

So problem is lack of power, and what I am chasing is the temp light.
Anybody work for GE?

just out of curiosity, is there a temp sensor on the motor and those wires are tied together instead of the temp sensor wires going to the controller being wired together?

Also, is the inner metal parts of the wires twisted together(electrical connection) or are just the rubber outer parts of the wires twisted together( physical connection)?

Are you sure you have P21? My drawing shows it as a Bk/Y wire.
Describe what you are doing to measure for +72 on P21?

Next step is pulling that 23p connector apart, releasing the retainer, pulling that Pin21 out of the connector and very gently pushing in on the tiny spring/wiper wires. (thinking they are not making good contact with the pin when plugged in).

I tried swapping controllers with another car. The new controller works great. The car accelerates and has the expected top speed.
The warning light is not on with the alternate controller.

The wiring for the temp switch is connected and +72 volts is getting to pin 21. Measuring between the temp input and 72V neg at the controller. The connector is clean, dry, all the pins on the controller are intact, all the contacts in the socket are seated.

The problem controller turns on the temp light, no code, no wrench, and lacks power.

I tried swapping controllers with another car

That is another good way to test. Not many have other cars of extra parts to swap around.

If you were wildly curious you might take your problem controller and gently pop the lid off and check for visual evidence of electronic mayhem.
Look real close at P21 and it’s surrounding traces. It may be a cold solder joint or bad trace in that area. You may find nothing. In which case, just close it up and send it off to FSIP.
You may find evidence that this board has had a degree of water intrusion and the whole board is an alien terrain of powder and voltage induced science experiment.

and lacks power.

And I think you realize that since the Temp Light is triggered, the controller intentionally pulls back on power output. This is normal.

Are there any settings in the T4 controller configuration for the motor temperature threshold?

Looking inside the controller shows water damage and blown components. It appears the water got in around the connector. I will send the controller out for repair.


This is the kind of stuff that can keep a guy awake at night.

Thanks for taking the time and actually taking it apart. I like it when an odd problem ends up with an “A-ha! There it is!” moment.

Are there any settings in the T4 controller configuration for the motor temperature threshold?

The temp sensor in the old GE motors were strictly a “Open at X(?) temp”. The controller sees this as a conditional state and not capable of viewing this as a variable signal. If conditon exists it only cuts back power. Unfortunately, the amount of cutback is hard coded and not adjustable either.

In the spirit of the great D. Harry You should as ask yourself “if you fee lucky, Punk?”
Only continue if this is within the scope of your talent pool. I THINK FSIP will not touch these things if they have been mucked about by weekend techs. (I’m not sure where I heard that, but I might be wrong).

I suppose if you wanted to carefully clean the corrosion with a toothbrush you could look for a break in the trace coming from Pin 21. Also look at the bottom of P2 on the board.
Do a bit of continuity checks and see if something can be jumped. In theory- all you need to do is put B+ on this pin and hopefully the Temp error will clear.

Oh, so many opportunities here…

/Walks away whistling…