Problem hooking up New Batteries

I just rounded up batteries for my GEM, following the instructions exactly, turned on the main switch and POP! There was a loud pop under the dash. I shut the main back off and now I’m not really sure what is going on. I followed the hook up right, I had pictures and diagrams to follow and I thought it went pretty good. I went back and checked everything, it’s right according to my diagrams. Would the speed controller have gone out? It’s been sitting a few years. I assume a loud pop like that isn’t normal.

Really, disappointed, I was hoping to have it going finally, but it looks like I either messed something up or it’s got issues. I had the dash off when I was doing all this. I tried smelling the controller and charger and I didn’t notice anything. It also made a quick electronic noise after the spark and then died. I didn’t look at the steering wheel gauge to see if it lit up, I just shut the main back off. But I guess if something’s messed up the damage is already done.

I checked power at the switch and it’s 75.8 volts, so should be right. If it wasn’t hooked up right I wouldn’t have the right voltage here. I guess it’s a bad controller. I wish I had checked the gauge before shutting it off to see if it turned on. It just made a loud pop and I wanted to shut it off now I’m too afraid to throw it back on but maybe it can’t hurt it any more if it’s fried.


Checked a few fuses. There are 2 10amp fuses on passengers side lower right, those were fine. Found a 400 amp main, it looks good thru the little window. When it popped it sounded like it came from drivers side. I don’t see any other fuses to check.

I went thru the service manual to see if I could find anything that would help, but didn’t see anything. I went out today and thru the switch again, there was a smaller spark up front and then an electronic buzz. The steering gauge came on and it’s displaying -15 code. The manual says that’s “low voltage”. At the shutoff switch it’s reading 75.7 volts so it should be fully charged. I am going to try plugging it in and see if it will drive. I don’t know why it gave a loud pop the day I first hooked it up. I’m wondering if the speed controller blew. I can’t find anything else wrong. I will start checking with a meter next.

I let it sit then turned master back on. Now it is showing a -04 error. I let the brake off but doesn’t go away. The car will not drive. I tried forward and reverse, the backup warning will come on. I get no lights, turn signals, brake lights. No more -15 error but -04 error all the time. Would that cause the car to not drive?

04 is not an error with the brake handle up. when you put the brake handle down the 04 should go away and you should hear the master relay come in with a LOUD POP.(Key on)

If it doesn’t push down on the brake handle REAL hard. The Ebrake switch is prone to failure and miss adjustment and is a common cause of no go.

note with the key OFF and the handle down you should get an alarm. This tells you that you parked with the Ebrake off.

Don’t get an alarm with the brake/key off. I don’t hear the master relay either. I turn on the main shutoff and the gauge comes on with -04. Like I said, when I first tried it after I put batteries in, there was a loud pop and then an electric sound like it was dying. I left it alone for a couple days, then just tried it again today. With the shutoff on, I checked power at the speed controller and it’s showing 75 volts. I checked at the main breaker and it’s only showing 1.5 volts or around that. I checked on both sides of the fuse, not getting proper voltage, but the service manual indicates the speed control won’t supply power if there are error codes?

The other strange thing is it doesn’t make any difference if I turn the key off or on, the error code is still displayed. I replaced the ignition with another part. It’s basically a toggle, two wires. I wasn’t sure if how I had the wires connected it would be on or off, I was going to swap them around if they were in the wrong position, but I wouldn’t think that would cause any problems.

I’ll take a look at the brake and see if it’s binding up. So getting back to the 04 or any code, is that true then, the controller will not work if there are errors? The loud pop I heard didn’t sound normal, unless it’s the pop that you’re referring to (master relay). Does it sound like a loud spark?

If the 04 code doesn’t go away when you push the handle down check the Ebrake switch.As mentioned previously it has to be adjusted properly and working.

Note your having a common problem. Suggest you set 2 or 3 hours aside and go thru All the posts in the GEM sub forum.

Down load and print out this manual (about 40 pages) Follow the trouble shooting tree and it might help you


I checked the break handle. I cleaned the contact points under that switch, they looked a little rusty, but still didn’t change. Constant 04 error. I’ll take a look at that manual, I don’t have that one. Not really sure where to go next on it.

Did you put your meter on it to see if it is functioning?

Put meter on each wire but I didn’t get any current. Unplugged wires and plugged back in. I just attached to a ground point and checked each wire while they were plugged in.


Your shooting blind. Control on GEM is not grounded, returns are hard wired. Only 12 volt service uses frame ground. You need to ohm out the switch. I think you need to have your dealer service the cart. You can end up blowing the controller and have a $400+ rebuild. Sometimes it’s better to pay the pro. Did you review the trouble shooting tree?


That’s what I was wondering when I first got it hooked up. Just gave a loud pop which didn’t sound normal. Maybe the control is fried. I’ll have my brother in law look at it, he’s pretty good at electronics. Maybe it’s just a bad switch.

I think you underestimate the complexity of the cart. Suggest you get schematics and have a good Gem mechanic help you out.

I doubt that will happen, showing the closest dealership is 2 hrs away. The car was running fine before it was stored. I’ve never driven or operated one before so I’m no expert here. I’ll have my brother in law look at it and go from there. He can troubleshoot just about anything.

so you know what the error is which is the parking brake circuit thinks it is set, so go forward with that circuit. Make sure the switch ohm’s out properly when pushed in and not. If it is ok then follow the wiring up to where the controller is and make sure that it has not rubbed and grounded out or become broken. The fact you know where the problem is means you need to follow that circuit from start to finish. I think you are worrying about the contactor pop too much.

I ordered a new switch, so we’ll see if that fixes it. I called in a repair place, they said if it popped like that it was probably the controller. He said 04 was the switch but it can also be a bad controller. When I told him that it popped when I hooked it up and it had been sitting for a long time, the controller likely blew. It was sitting in a garage with high humidity, so it’s probably bad. I’ll replace the switch first since I already ordered it. But I’ll probably be sending in the controller if that doesn’t fix. The error code can cut power until it’s cleared so if switch doesn’t fix then it’s probably a bad controller. Oh, well.

Ok, so made some progress on getting my GEM going but am stuck again.

I sent in the controller to get repaired. It was indeed bad, multiple faults. Also had it reprogramed for 14 inch tires and wheels to up the govonor a little. So the loud pop I heard was the controller going not the relay. Again, it was showing a 04 code. It would also show this code whether it was turned on with the key or off. Which I was told could be a bad DC to DC board. I also did not get any 12 volt power to lights or horn and such. Guy who repaired controller suggested getting that replaced since there was a recall on it, but I had to haul it 2.5 hrs to the nearest place that services them.

So I ended up leaving it because they didn’t get the work finished on Sat. I’ve been getting the run around at the place that works on it. They won’t call me back. When I call they said they didn’t check it after they did the work. They’d have to get it back out and try it with the key. Then the next day they said they got the recall done and if there was anything else I needed done on it. I’m just confused. I told them what I needed. I suspected the DC board was bad and I would assume they would check after replacing it to make sure it was functional. So they said they’d have to get it back out the next day and check. They called me back now today after the 3rd day and said it’s not doing anything. The gauge doesn’t light up now, which it did before. So I told them it was fine before with the old board but no power. I asked to speak to the tech, I got transferred but the guy I talked to wasn’t the one that did the work on it. I got a lot of “I don’t know” and “not sure”. This just sounds funny like maybe they screwed something up and don’t want to be responsible for it. The DC board replacement is covered under the recall so I shouldn’t have to pay for it. I don’t mind paying them for the work if the problem isn’t the DC board but I would think the guage would still work if they replaced it right. Now apparentaly I don’t have that. So worse off then I was before talking it to them.

I realize they’re not making any new money off it, but good grief their customer service sucks. How do you replace a major component and then not check to see if the work was done right? I’m about ready to just go pick it up and haul it to another GEM service place which is about the same distance away and have them check the recall work.


Guy who repaired Controller. Usually Controllers go back to FSIP for complete rebuild at $353. Do you have an individual repair your controller.

Other than no 12 volt power did the cart function properly?

DC/DC board replacement. Did your repair shop install a new DC/DC unit which is an aluminum cased unit?

Don’t be in a hurry to take it to someone else. Warrenty issues are involved. If you take it somewhere else the guy that did the current work gets off the hook.

[quote=OLD HOUSEBOATER;30238]Hmmm

Guy who repaired Controller. Usually Controllers go back to FSIP for complete rebuild at $353. Do you have an individual repair your controller.

[B]Yes, Ride For Fun refurbished.[/B]

Other than no 12 volt power did the cart function properly?

[B]No, didn’t do anything, gauge showed -04, no lights or anything. Now the gauge doesn’t work though, but since I can’t talk to the tech that worked on it, I’m not sure. They haven’t called me back today, big surprise.[/B]

DC/DC board replacement. Did your repair shop install a new DC/DC unit which is an aluminum cased unit?

[B]There was the DC board kit and the handbrake for recalls, which they completed. I don’t know if it’s aluminum case, I haven’t seen it. I’ve heard it’s completely different than the old unit. The service person that answers the phone said it wasn’t doing anything. Didn’t show anything on guage now, just a red light. But I’ve been trying to talk to the actual tech, just can’t seem to get him on the phone.[/B]

Don’t be in a hurry to take it to someone else. Warrenty issues are involved. If you take it somewhere else the guy that did the current work gets off the hook.[/quote]

[B]Right, I know. I’m worried they messed something up when they did the DC board. They said they charge 85 per hour but I had guage indication before they swapped the DC board, now it isn’t even doing that. That’s if I’m understanding them right, but without being able to talk to the tech, it’s difficult to say.[/B]

There are a couple of interlocks involved when the DC conversion is installed. Your problem might be in one of those areas. The installation instructions cover replacement in cars using Shott, Zivan and DQ chargers, Its a complicated conversion and easy to miss something. The installation will have to be reviewed in detail and the problem corrected.

The big mistake you may have made was taking it to a Polaris dealer. They have no factory training. I also would have to drive an hour and a half to get my car to a non Polaris repair shop for trusted repairs. Polaris will some day dump GEM!

It wasn’t Polaris, an off road dealer. Got a call back they said it was running now. Batteries were low. I hadn’t charged since I purchased back in late February. I checked them a couple weeks back, I thought they were at 75.5 volts still, that was after I got the controller back. They said they drove it around today, so I’m picking it up tomorrow. Can’t wait to have it home and working for once. So recalls are done. I need to finish up the bed and get the new lights hooked up. Also still need to dump the differential oil.

I looked under it briefly but didn’t see the drain plug or the fill spout. Where exactly should I look? Also what brand/weight are you guys using and capacity. Thanks.