I did a bad thing to my GEM

I recently bought a 2009 E4 and decided it needed to be washed, I figured since it was designed to be driven in the rain, as long as I didn’t spray directly onto the hood opening, I’d be ok. Well when i finished, I got in and drove about 4 blocks with nothing amiss. I stopped at a light, and after about 30 seconds of sitting there tried to take off, but absolutely Nothing! Just totally dead. The display showed a wrench, turtle and thermometer. I tried turning key off and on, master switch off and on, etc. I was 2 bars down, but that shouldn’t have stopped it dead. Got it towed home, there was water laying on top of the charger and here and there. I’m a decent auto mechanic, but know nothing of electric cars. Any suggestions of what I can check or do?

I had the same problem and just let it dry out for a day and it was fine. Several months later the controller went out in it so I had it rebuilt. Since then I have washed it several times with out any problems so I believe my issue was water got into the controller and after having it rebuilt they sealed it properly.

Thanks, I hope drying will work. Where did you send your controller to be rebuilt?

FSIP (Flight System Industrial Products). If you sign up as a business you get a pretty good discount.

Good to know. And I AM a business. :slight_smile:

You were right David. This morning it came to life and operated normally. The only thing is the odometer now reads 40,176 miles instead of 536. lol

Pretty sure the odometer reading is stored in the controller so just one more thing pointing at the controller as possibly the problem.