Current Limiting Mode

I just purchased a 2005, and have put maybe 8 miles on it in the last 2 days, running around the village. I ran down to the store this afternoon, and on the way home the Gem went into current limiting mode (turtle showing), but no error codes. The batteries seem to be charging normally and I started with a full charge indicated. I do go down a moderate hill into the village, but the car was running normally until halfway home (maybe 1/2 mi) when this happened as I started back up the hill. I let it rest (as it is a living being, right?) and turned the lights on for a little while, but now it seems to remain in the current limited mode, although the turtle light isn’t on.

Can anyone shed some light on what’s happening? Thanks.

Any chance you flipped the Turf/Road switch by accident? I did that once and it took me an embarrassingly long time to figure it out.

I wish! No, I checked and rechecked that.

First I’d try turning off the main power switch (under the seat) and leaving it off a few minutes with the ignition switch on (to drain any residual charge in the system) then turn off the ignition and power up the main disconnect. I’ve been told that “reboots” the controller and MAY clear the problem. At least it’s easy to do and doesn’t cost you anything to try it.

Next I’d charge it completely and test all the cells of all the batteries with both a hydrometer and voltmeter to see if the batteries are all “up to snuff”. In my GEM, I found one cell that was totally dead and a couple that were weak. I gulped hard (at the cost) and replaced all the batteries with a set of Trojans even though they were only 2+ yrs old when I bought the car. I was told they would be trouble free for a couple more years. Ha! They were Interstate Marine batteries and I’ll never make that mistake again. Marine batteries simply don’t work very well in this application in my opinion.

Anyway good luck! I know it’s frustrating when your GEM doesn’t work. I went through a round of that myself when I first bought mine so I feel your pain.


Al–I tried your suggestion, and it may have reset the controller–I’m not sure. because after I went down the first hill into the village it immediately showed the turtle again. I was near the shop, so I stopped and they tested the batteries (gel), and while all showed full charge, when a load was applied one of them dropped just below the functional range, so I apparently have one battery going bad. Didn’t quite make it home, so I was “stranded” for the first time in my “new” Gem.

So: it’s ok to replace only the one failing battery, right? Anyone know a very quick way to obtain one?

Thanks again.

How new are the gel batteries? Would they be replaced under warranty?

Just my experience: IF the batteries are “almost new” then yes I’d replace just the one that failed prematurely. HOWEVER if the batteries are more than a “few months old” (whatever that means to you), I’d replace them all.

I had one failed cell and a couple more weak cells in just one Interstate marine flooded lead acid battery in my pack which were a little over 2 1/2 years old. I decided to spent $120 to replace just the one and keep the rest and see how that went. My “good idea” lasted a couple of months and I continued to have problems with my battery pack. I suspect there were probably other batteries that were weak but didn’t test “bad” and the failed battery put a load on all the others and pulled them down.

Finally in frustration and desperation to solve my problem I finally bite the bullet and replaced all of them with new Trojans (about $1200 for the set) and have been trouble free ever since.

The general consensus seems to be that “premature death” or “infant mortality” on new batteries is understandable and warrants replacing the bad battery. Anything more than that you’re probably better off replacing them all.

I also personally believe that marine batteries simply aren’t up to the task being asked of them in use in a GEM.

Don’t know how much of the above applies to your situation so salt and pepper to taste.


Thanks, Al. My batteries are probably 5 years old. If I replaced the bad one, would it hurt the others? If replacing just the one would get me to October, it would be ideal. Then I could replace the others in the spring…reasonable crap shoot?

Personally I’d replace them all at once given they’re already 5 years old.

The new, strong battery will take more “abuse” given the other batteries are undoubtedly weak right now at that age. It would be a shame to have it pulled down by weaker siblings and then everything else being replaced with new in October. Then you’ve still got one potentially “abused” and weak battery in the string.

Plus there is no guarantee that you don’t have another battery in the string ready to fail as soon as you replace the one you know is bad. Are you willing to risk another stranding if another one fails?

Just my $.02 but I’d opt for all for one and one for all!

Perhaps obvious If you do replace them, you’ll either need to stay w/ gels OR have your charger reprogrammed to whatever battery profile you use (say FLA or LiFEPO4).


Yes, makes sense. I’d love to think about the LI, but that’s whole different kettle of fish. So I’ll probably go for the Gel and keep it simple. Thanks.

In my educated opinion, 5-year old gel batteries are at the end of life and all 6 should be replaced. Without a cycle-tester, you cannot see how much they’ve degraded in their 5 years of hard duty. The failure of one battery at that age is the indicator that all the rest are soon to follow.

If I were you I’d bite the bullet and put in 6 new gel batteries. If they give you 5 years of adequate range then you’ve gotten your money’s worth IMHO. The cost of the batteries is almost never figured into your cost per mile but it’s pretty significant on a vehicle which averages about 15-20 MPH and 10-15 miles per day. If it’s driven 5 days a week for 15 miles for 5 years, that’s 5 * 52 * 15 * 5 or 19,500 miles on a set of batteries. I’d bet your miles shown are significantly less than that.

If a set of batteries costs $1200:

Even at 19,500 miles per set of batteries, that’s 6.15 cents/mile
If your GEM has, say 6000 miles, that’s 20 cents/mile for the battery replacement.

If you pay 18 cents/KWH for electricity, your cost to charge each night is only about a dollar so your electricity cost per mile is something like 3-4 cents/mile making that battery replacement cost a SIGNIFICANT amount higher - like 5 times higher!!!

Electric vehicles can be the right solution for your particular need, but they’re hardly “economical” when you consider all the costs and not just the cost of electricity.


Well said and excellent cost analysis.

I’m afraid our beloved GEM’s aren’t as economical/practical as perhaps we’d like our spouses to think!


Ok, so I bit the bullet and bought six new gel batteries for my recently-purchased 2005 Gem. I learned something, so a report is in order:

The two outside front batteries were easy enough to extract by removing the hold-down bar (had to remove one side of each battery handle hinge to get it out, then replace them so as to use for lifting), tilting the battery vertically and with a little wiggling and muscle pull them up and out. It had been suggested that the two middle front batteries would come out in similar fashion. However, a couple tries showed that method not too workable, as I found it impossible to get the two middle front units up or out past the brackets, stays, chassis structure, brake cables, etc. And, even if they had, the hold-down bar for rear two was almost inaccessible, requiring reaching around the rear wheels/tires into a very small space to unbolt and then extract the hold-down bar. And the fight to somehow push the two rear batteries forward into the space where the two middle front batteries would have been (if they had come out the front) looked to be, well, a long shot at best, and then they still would have to be wrestled out with the same difficulties as enjoyed in extraction of the two middle front ones.

But after staring at the scene for a few minutes (as in Zen and the Art of Motorcycle Maintenance) I suspected that it would be easy to remove the rear ‘spat’ (it was…10 easy-to-remove bolts), which then allowed open space and easy access to the rear battery hold-downs and the bar and so made it very easy to remove the hold-down and get the two rear batteries out the back. Then I lifted a little bit and pushed the two middle front batteries back through the rear space where the 2 rear batteries had been–again, relatively easy.

Then I reversed the process and installed the new set without difficulty. And I was off at full-speed, no error messages, no problem.

Until I ran the car about 5 miles and was going along at maybe 30 mph when I heard some weird noises up front, lost about 1/2 power and saw a yellow wrench on the lcd display and what I think was the code 81 at the top of the display (no more speed readout). I limped back home, shut it down.

The manual says code 81 is a problem with the the tachometer. But would that result in loss of power and weird noises coming from the motor area? When I insert the key and turn it on now, there is no wrench, no error code, the display looks normal. But as I start out (in R, L or H), the car loses power completely and displays the yellow wrench and the code 82, which reads “armature current exceeds 280 amps for 3.5 seconds and the accelerator pedal is calling for maximum performance in the control mode”. Huh?

So–has anyone experienced anything like this? I can’t really describe very well the noise I heard when this happened except to say it sounded kind of metallic and it was clear something was wrong. I don’t see anything unusual in that area now to report.

Any suggestions for the next step in trying to figure this out? Thanks.

I have a '07 E2 and have experienced a similar problem. After 16 holes of golf in the turf mode, I experienced a shutdown with the led displaying red battery power and the motor was so hot you could not touch. Long story short…I replaced the motor controller first ( no help) then the drive motor (no help) and was at wits end trying to determine a fix. I raised both front wheels and both turned freely which determined nothing was dragging to cause the motor to overheat. Batteries (Trojan gels 1 yr old) load test was successful. If I have overlooked anything will someone be so kind to inform me. Thanks

1 Like

I think you’ll find the magnet inside the passenger end of the motor is busted apart. The controller picks up the speed (tach) by sensing the magnets rotating around a pickup coil. If you lose the magnets, you’ll get the errorcode 81. You can take off the end cover and you should see the magnet and sending unit.

The other error code is more worrisome IMO. If a piece of the magnet flew into the motor, it’s likely to cause a serious problem (short circuit) and the 82 errorcode sounds about right. You might be looking at a replacement motor at this point. At least that’s where I’d start looking.


Thanks, Al. I’ve tried every kind of tool and device I have (phillips, hex) to get that part off, but nothing I have fits the 2 little screws…do you happen to know what kind of screws they are? They look kind of like very small torx…

Sorry no. I’ve never had mine off. I just replaced my OEM motor w/ a 7.5hp R4F unit.


[quote=tomarys;16911]Thanks, Al. I’ve tried every kind of tool and device I have (phillips, hex) to get that part off, but nothing I have fits the 2 little screws…do you happen to know what kind of screws they are? They look kind of like very small torx…[/quote]If it looks like a 6-pointed star, it’s a Torx. Just get the appropriate size (or multi-bit) Torx driver. Don’t mangle the screws with the wrong tool.

Indeed–been there, done that (in my eager but ignorant youth). Learned. Thanks.

Turns out the screws for the speed sensor assy are torx–a T10 bit worked.

So the magnet is indeed in pieces, and one tiny segment of the disc is missing–I’m not sure if it dropped out when I pulled the thing off in my gravel driveway (where every piece is exactly the same size and similar color as the magnet chunk), or if it’s in the motor.

At this point, my question is: can you energize and turn the motor with the speed senor off without hurting anything?

My other questions is: how can they design a motor where a tiny piece of ceramic magnet can, when it inevitably breaks, ruin the motor? I don’t yet know if my motor is ruined, but if it is, I think Gem owes me one, don’t you? :wink:

The magnet breaks, usually, because water infiltrates the sensor around the O-ring and rusts the motor shaft. Rust is physically larger than steel and thus forces the magnet to expand till it breaks.

At up to 4100 RPM or more, the motor can sometimes sling the broken pieces off the shaft but usually they should stay in there. There’s a bearing on the shaft that will keep pieces from falling into the motor so I suspect either the piece is still buried in there or has, as you surmised, fallen onto the ground. Drag a piece of metal around in the area and it’ll likely pick up the magnet piece.

The motor will work fine without the magnet but the controller won’t see the RPM and thus cannot perform field-weakening to obtain higher speeds/lower current as you get above about 1/2 speed. You will also generate an error on some controller firmware and lose regenerative braking at or near top speed, reducing range even further than the non-functional field-weakening function.

The magnet is epoxied in place and can be replaced pretty easily and secured with epoxy. You’ll want to sand the end of the shaft with emory cloth to remove any remaining glue and use a strong magnet while doing so to capture any small bits of metal removed by the emory-cloth. You don’t want metal dust getting into the motor’s guts if you can avoid it.