2002 won't increase speed when switching from turf to run mode. Help please!

Hi everyone - I just refurbished this Gem car and it ran perfectly while I had the wheels off the ground. In turf mode it would go about 15mph and about 26 mph in run mode. I took it out on the road and it goes about 13-14 mph in turf mode and when I switch to run mode it starts to go faster but quickly reverts back to about 13-14 mph. I changed to another accelerator with the same result. Any ideas would be greatly appreciated.
Thanks Jim.

Maybe a bad switch? or and open/short in the wiring to the switch?

The switch seems to work fine because with the wheels off the ground and I move the switch from turf mode to run mode the speed does increase to 26mph but if I do the same thing on the road under load it basically stays at turf mode speed.

What is your battery pack voltage in those scenarios?

I’m going to charge the new batteries up to full voltage and try to determine that once it stops raining here. Thanks Jim.

Here is what I’ve done. Cleaned all connections at controller and motor. Batteries all at 12.83 volts. Checked all cells with hydrometer all good. Voltage at controller 75.6. Voltage at main fuse 76.9. Drove down the road in turf mode hitting accelerator hard voltage dropped to 72.4 then leveled off at 74.6. Did the same in run mode from dead stop voltage dropped to 69.8 then leveled off at 72.5. All readings were taken at the controller.
Still no increase in speed in run mode. This was on level road. I then went down a hill and the car kept surging and got up to 28 mph. Coming back up was slow going.
I also tested the motor today and the ohm reading from f1 to f2 was 1.5 but the reading for a1 to a2 was like 36.9? I thought that was supposed to be .2 - .5.
Possibly new motor time ? Any other tests I can do before pulling motor out?
Any help would be appreciated.
Thanks Jim.

@Old_Houseboater can likely comment on the expected A1-A2 value.


Your motor probably needs to be serviced.

How old are your batteries. Do a brake load test on each battery after motor service., if problem persists.

The batteries are brand new and I found that I forgot to turn the master disconnect switch off when I checked the motor. Checking the motor again showed f1-f2 at 1.2 and a1-a2 at .3 so the motor is good. I decided to change the connector with the magnet for the speed sensor for the heck of it and for whatever reason that seems to have fixed it. Hooray!!! Don’t know why though. Thank You to everyone that viewed and responded and hopefully this may help someone else with this problem down the road.

I just replaced my stock gem motor in my 2005 e4 with an advanced D&D motor and now only High mode works not low or “turf” mode as its called on older models.