Parking Brake Light won't go off

I have a 2012 GEM E6 and I’m at my wits end with it.

It stopped working with an error code 21 about 3 months ago and the dealer said it was the accelerator. I replaced that and it didn’t fix the problem. They then said it was the controller so I had it sent to Ride-4-Fun and they tested (it was bad) and they rebuilt it.

I plug it back in and it’s still not working. I’m not getting any error codes but it won’t engage in drive/reverse. The red parking brake light is on and won’t come off (of course even after I disengage the parking brake). I do have the manual and it says to test the brake light circuits. I don’t really know what I’m looking at to test the circuits or finding the relays.

The alarm will go off if I turn the key off and disengage the parking break so I know the switch to the parking break works. Is there a way to “jump” the circuit and override the switch? I’ve spent so much money trying to get this fixed and just want to know if that’s the problem now.

Any help would be much appreciated.

Thank you!!

See if p13 is jumpered to B-. Controller should have come with a note.
I need a throttle for testing. Did they give you the “bad” parts back?

Thanks - I’ll check. What is B- ? I’ll check the box again but I don’t think I saw a note in the packaging. ON the controller itself it did say for older models, it would require the jump.

I have both throttles. I want to hold on to both of them until I get it working again in case one of them is actually bad. Give me some time to get it working and I can share one with you.

The brake lights are activated by a pressure switch on the brake master cylinder. You can test it for continuity when pressing the brake pedal. I wouldn’t think it would have anything to do with the parking brake side of things but wouldn’t hurt to check it. The pressure switch failed in an open state in my 2013 E6 and had to be replaced.

1 Like

B- is battery negative.
If there is no pin in 13, I can send you a pigtail.

1 Like

There is a pin in 13 and it’s going to the J5 plug in the dash. Would I hurt anything if I jumped the 13 pin to B-?

To be safe, cut it and connect only p13 to b-.
Check fluid level and switches first.

1 Like

Well - I’ve come full circle. Hooked 13 to B- and now I’m getting the original error code 21.

I officially have no hair left.

Error 21 is pin #7 voltage too high. Should be under 4.5v. Use B- for meter common.
P7 is the command from throttle pot, varies with throttle from 1v to 5v ( or 10v). Don’t remember!

1 Like

Thank you! I will try tomorrow and report back!

I know this sounds crazy, but pull and check all your 12v fuses. I was have similar issues (defiantly the issue with the PB light not going out and I seem to remember -21 as well) when I was testing some T4 controllers. Turns out that during some other things I was doing I removed some fuses, ones that have nothing that would control error codes or PB issues. I checked and replaced all the fuses and bingo the controller started working again.
It is probably a shot in the dark but who knows???

1 Like

Thanks! I’m so desperate at this point I’ll try anything. I’ll try tomorrow and report back!

Grant reported similar with keyswitch. Intermittent power causes random codes.

Okay - I checked all fuses and they were all good. I also checked the volts on pins 1,2 and 7 and they were all getting no volts. I double checked on B+ post and was getting 76v reading from there so I know my volt meter isn’t bad.

I tried both my old and new throttle and am getting the same 21 error code.

Isn’t 1 and 2 supposed to read 72V?

If B+ is 76v the contactor pulled in. So 1 and 2 must have 72v.
Are you testing relative to B-?

When I say B+ I mean the positive input to the controller. I’m using The negative terminal for B-
That is what I have P13 grounded too.

Maybe I’m not testing it right. I’ve been sticking the probe in the top part of the plug. Should I be probing the wires through the insulation?

You may have to go through the insulation.
From B- is correct.
Pin 7 is what causes -21.

K. I checked again and 1 and 2 are getting 72v. I’m still not getting a reading on 7. Ride 4 fun says on occasion they will get a rebuild that is bad. Could that be it?

Voltage comes from the throttle pot.
Supplied by 5V P9.
Pin 9 has 5v when key is on.
Pin 7 has 1 volts at zero throttle and 4 volts wot.

If nothing at P9 it could be bad controller, but there is a work around.

1 Like