GEM eL XD Truck - Upgrades - Lithium, R4F Motor, On-Board Solar Charging, 72v to 110v Inverter, Lights

#79

@Inwo One question: what is the little silver wire sticking out from the one end of the com2 cable that connects between the BMS brain and screen? I Thought it might be for a ground. If so, which end and ground to what? The frame of the GEM is not part of the electrical system AFAIK. I have taken measures to isolate 80VDC primary battery supply, 12 VDC accessory converter, inverter 120 VAC, and I even have a 72-to-5 VDC supply to operate the addressable LED pixel strips I am using for lighting.

Moving right along with the install… The box is re-assembled in the tray. BMS mounted and actively balancing. Inverter mounted.


I popped open the inverter to add an extension wire to the power switch so I can switch it from the dash. The switch just controls a relay switch for the high current. Looks to be well made.

#80

Ignore the wire. It’s the shield.
Good practice is to ground it on one end only. You are correct, there is not a common ground to work with.

#81

Thanks @Inwo

Next, I just want to verify that this is where the white wire to enable / disable the DQ charger goes. This comes from a bundle of red, green, black, white from the DQ. Does the orange with black stripe wire get left off or reconnected? Looks like the connector you put on it is to reconnect the orange wire but did not want to assume.

#82

The white disable wire connects to white from charger.
The Orange goes back to sensor on batteries.
Sensor is not used with lithium. The orange wire should be available near your bms. In that case, leave it connected up front.

#83

Dave ,

On all the previous conversions I removed the temp sensor and ground the wire to battery neg . On this last one I left it the way was . Deltaq works fine . I think the charger wire goes thru the sensor and the other orange wire goes to ground so the charger is still seeing ground thru the sensor . Is there a reason we have to ground charger to neg and cant leave it the way the factory has it ?

#84

The sensor has 10k resistance. It may work, but it may have issues down the road.

#85

BMS will not start. I had it hooked up to the battery alone at first and it seemed fine. Now every time I switch it from ext to bat the screen comes on but there is no memory. It says:
LIPO
00 CELL
START
I can change it to different chemistry. I can change the cell count back to 20, but selecting start has no effect.

I have everything hooked up and wanted to check the pack one more time before throwing the switch. I put a 750A cutoff switch right between the battery and the fuse in the negative line.

Thoughts?

#86

Tried a different cable for the com wire from brain to control unit and it worked. Must be some issue with the extended com cable… i will check for loose connection or damage.

#87

The rj connector pins can be problematic.look at the gold spring contacts inside the sockets .

#88

I’m looking to rewire the connection from the main BMS to the screen BMS. I need to buy a new wire and the results for rj45 seem to be network size connection and the connector for the BMS seems to be half that size. What size connector is it? Sorry, this is the only place I saw the connector called out. Thanks

#89

Auto correct changed it to rj45. I meant the generic rj connectors.
Rj9 called handset cable or 4/4.
I plan to make a batch soon. I have shield cable for putting them together. Rj9 takes a special tool.

#90

These are a bit confusing. The ones used here are the smallest variety.
Headset / handset 4P4C
RJ9 = RJ10 = RJ22

#91

I just built a batch of 15’ using high quality shielded/stranded wire.
$25

MVC-015F

Sorry for high price. :frowning: I have to drop all my own projects to have the time. :slight_smile:

#92

I did end up swapping the 4P4C wiring between the Chargery screen & brain. It works fine now.

Finally, I did throw the big switch. The spark & pop produced when the circuit was completed was not trivial. It actually very slightly blackened the contact. You may notice dielectric grease in the picture as I used on all critical connections. It would make me think twice about opening or closing the switch unless in an emergency. Is this normal? Is there a way to avoid or reduce the effect?

It was surprising and concerning but did no damage as far as I can tell.

  • I flipped the main GEM breaker and everything came back to life!
  • Successfully completed the first charge.


    One note… when the charge is complete at just under 82v or 94%, I noticed that the GEM dash screen would periodically come on and show 99% and charging for about 30 seconds. This was concurrent with the green enable LED from the BMS. It seems that it is just topping off the charge. At this point any cells that were slightly above 4.1v (like 4.105) showed as “High”. Is this normal to cycle the charger on an off after reaching full charge? Do you guys put the charger on a timer or just leave it plugged in?

Anyway, at this point all the main systems in the box are installed. Battery, BMS, Inverter, Solar controller, 5v supply for LED lighting.

Next on my list:

  • Dash work: 3 switches for lighting zones, inverter switch, solar switch. Also want to make some kind of mount or box for BMS screen & solar control.
  • 120 VAC wiring (outlets in cab, Bed / Max Box, external on rear end) you can see the gray UF cable dangling & taped.
  • Install solar panel on roof rack. You can see the white marine grade 12ga DC cable dangling & taped. The solar control is powered by the panel so I did not get to power it up yet.
  • LED addressable pixel strips and controller
  • Add 4-pin trailer light wiring.

I will probably test drive it in the near future so I have a baseline. Then I will install the magic magnet and test. Finally I will swap the motor for the Ride-4-Fun motor.

Here are some current pictures





![20190519_235252|690x388]
(upload://z21UhDCUw5yBnyhLx3Jrg2QRzX7.jpeg)


#93

What is the bms set to on the first few settings? The charge restart may be set too high.

#94

I am not sure how to get into settings. Actually, I need to get a pdf of the manual for the BMS. The Chargery site is down.

#95

What was connected to cause the surge? The inverter caps may be the reason. A precharge resistor across the switch helps.

#96

Everything was connected at the moment the switch was closed. Please elaborate on the precharge resistor (not something I am familiar with ore how to install).

By the he way, I just want to pause and say thanks again. The “free” expert support is indispensable.

#97

Hold the start switch down to enter prog mode. Repeat to go back.

#98

:+1: I will try that later today after work.