GEM 2008 BDI Not working

I have a 2008 GEM E2 that I just had the batterires replaced. It is fully charged and driving great. All of the LCD is working fine except the BDI is showing the red line (no yellow or green lines) yet the batteries are fully charged. Any ideas on what to look for would be appreciated.

cycle your main battery power for .30 sec. Then power back on. See what happends after the reset.


Thanks for the suggestion. I tried turning off the main breaker for 3 minutes but that made no difference. The GEM is running great. I have 15 miles on this charge and still going strong. All other features of the LCD appears to work fine. It’s just the battery indicator that is stuck on Red.

Plug in to charge again. Then if that doesn’t work try the reset again and plug in the chager again. I had the problem on my 2012 and resolved it that way as per GEM. I hope it works . Let us know.


also make sure your outlet have a fult protector. Your charger would trip it under the conditions you describe.


Tried charger on and off, 100 amp breaker on and off, both multiple times. Still no change. I’m going to leave the 100 amp breaker off overnight just to see if that does anything.

Your Gem car got a main breaker also. I was refering to that one.


Yes, the 100 amp breaker inside the fuse cabinet IS the main breaker; right ? Is there another one some place?

I don’t think so. You discribe the correct one. I’m hopping you can resolve…


You can also turn the key after you turn off the breaker. I’m sure you tried that already. That would tell you if it was mod.


Update. I let the batteries drain all the way down and then tossed it on the charger last night. This morning it was fully charged and the BDI is now working perfectly.

That is good news! :happy:

the dark side of electricity… I’m off to see if my guy has found the problem in my GEM this week and if he has the Battsix working