Code-51 controller issue

I’m getting a error code -51 I went threw the trouble shooting guide and went step by step. I got to the part where you check all your connections and I found that I had the negative and positives switched backwards.

I switched them back around to where they should be and tried again and still I have the same error -51 ( the controller never sparked or smoked like when you hook something up wrong but that might not mean anything in this instance

Have I damaged the controller and if so can it be repaired and who does such work

Thanks in advance

You might try Ride-4-Fun. Their website indicates they “rebuild” controllers.


hi Gwest… the error showing might mean you have a low voltage battery… have you checked each battery to see that they are all fully charged and that they read in the 14’s or high 13’s… remember the batteries opperate as one


Yes the battery’s are fully charged - check
I did the trouble shooting Gide and traced voltage all the way back to the head (or input of the controller) voltage at controller - Check
Voltage at the solonoid but no voltage to kick or turn the solonoid on.
Fuse is good- Check

Gwest… I’m back to my disclaimer… I just drive my GEM car and don’t understand what makes it run… like Al… I say call someone… my choice is Lee at Gem Car Parts Direct | The Nations #1 Source for Gem Car Parts 888-677-4961… or on here Daniel GEMmechanic


Ok thanks for the tip I was hopeing Daniel would stop by and see this post

Not sure that this area is a better place to post problems versus the full forum below

I went threw the trouble shooting guide again.
I traced a potential problem to the Black wire on the contractor coil (photo) it’s the black wire on the right. When I measure voltage I get 76 volts. (This is with the brake off ready to go car in neutral) then when I switch the key off the voltage drops to 0.687
The trouble shooting guide says if the voltage falls of to replace the Main Contactor coil. So yes the Contactor coil is not opening and closing.

I must be missing something: with the key “off”, I’d expect the voltage at the contactor to drop to zero. With the key “on”, I’d expect the voltage to be 76v. To me, that sounds about right. If the contactor doesn’t close it could be a contactor issue or perhaps a controller issue.

I’d STILL call or try to talk w/ someone with more knowledge before I started replacing expensive parts.

Ok My solonoid problem Some how fixed itself. Yes that’s right all of a sudden it’s now working the way it should. Only thing that might have fixed it was the chargers fireing up and who knows??? I have no Idea why it’s now working???

But now I have Error code -27 manual says "12VDC Buss voltage is too low (less than 9.35 VDC)

So I go to check voltage at the MH20 pin1 ( that’s the large black connector that go’s into your controller) it says that their should be 12 volts at pin 1. When under a load (headlights on) When I check pin1 I have 78 volts!!! At the controller. (That’s not good) trouble shooting guide says if voltage stays above 9 volts under load then Replace controller!

I’m totally chasing my tail. I got up this morning to have another crack at it and now I have No Error codes and no movement just flashing 8888

I have another GEM car here to cross check my wires and everything Looks good so I’m guessing swapping out a controller in in my near future.

I made a call to GEM parts and they say if you swap out a T-1 for a T-1 it’s no problem but if your switching to a T-2 you need a pin converter wire harness it’s a $20 part to make a car that has a T1 controller run a T2 controller

Ok so if you didn’t catch it in the first part of the thread, on accident I hooked up the controller backwards + to - backwards. I’m sure this was the start of my issues. A new controller is $800 and R4F will rebuild your controller for $500. R4F claims that the T-1 controllers are problem plagued and that the T-2 controllers are more reliable. I just so happen to have a T-2 “laying around”. It even has the T-2 to T-1 wire harness adaptor. (Score) so I will install it this weekend and see if the new controller fixes my problem’s
On a side note. I think the wire harness on most gems support a T-1 controller and the factory didn’t update the harness they just added the adaptor at the controller as a quick fix. And in retrospect it’s a smart way of doing it. This way you can switch between controllers by simply adding or removing the wire adaptor.

Could you post the GEM part number for the wiring adapter?

Sure it’s part # 0105-00678

So I threw in the New controller. Power up an I have Flashing 8’s , Humm scratch head and proceed on I push down on the throttle and it’s working and the dash is in Normal Mode. But NOW I’m getting code -90 I did a search here and it says
grounding out terminal 1 or Input sensor error. Any help on fixing this? any trouble shooting tips on this. Thanks G

i called the gem service man today because i purchased a t2 controller for my gem (came with t1) because it was not working correctly. he informed me you need the wire adapter for the gauges to work and also some wire in on the big plug needed a jumper for it to work. i am searching for info on how to do but no luck. if anyone knows what he was telling me to do i could use the help to get my cart going again. then pin he told me was somewhere in the 20s on the chart (i think 23) but not sure what to jump it with.

Look for a thread T-1 to T-2 swap out. It GOs over the wires and stuff you will need to switch a T1 car over to a T2

Here is a link to the thread

Thank you so much. I look for hrs. I thing the word swap in my search was the ticket :slight_smile: I was searching upgrade instead and stumbling.