2015 E4, JERKING and some other weird issues. Wont go into drive sometimes

I have paid the local gem dealer hundreds of dollars and they have not figured out the issue yet. Hoping you guys can help.

2015 Gem e4s,

  1. When you drive it around for a minute and come to a stop, put it in reverse, it wont go anywhere. If you turn it off or hit the kill switch then the cart will drive in reverse again. This also happens into forward.

  2. I parked the cart for 5 days, and now its JERKING like crazy in FWD or Reverse. Soon as you hit the gas its like the cart is banging, it will move but shaking.

  3. It has code 81 *speed sensor which i replaced and that seems to have fixed it, but i cannot drive the cart really to test since its jerking so much.

I checked all the battery terminals, and the cart is getting over 72 volts. I replaced the fws/rvs switch as well. The Dealer wants me to try replacing the motor… which i dont see how this could be motor related? Any advice would be appreciated.

Update here: Tried to move the Gem up the driveway and it was slowly moving/jerking and then now it wont move at all. Its trying too , i hear a small type of grinding coming from the front, smelled burning. Opened the hood, the motor was the only part that seemed super hot. Didnt see any connections burned off. So perhaps the motor is the issue here. Kinda crazy 2015 with bad motor already. And its weird that it would drive fine a week ago, but having issues going into reverse. Not sure how thats related to the motor.

I have had 2 motors and one controller go bad on my 2014 (same as 2015) . Were are you located ?

I am in Maryland. I just want to make sure the right thing is bad before i replace the motor and its actually the controller etc.

If you have the black 7hp advance motor my guess is that is it . They usually start jerking If they sit for an extended period of time . I had to pull 2 out and service them to get them to run right again . But once done they are great motors . The controllers usually start throwing random error codes . 90% chance its the motor .

If you are ok with swapping the motor out , we can get you taken care of for a lot less than a new one .

The only options I am seeing are some used motors on ebay, or a ride-4-fun motor for 850$. What are my options? motor rebuild? who does that type of thing?

I will pm you with a couple of options

i service all GEM motors $150 including commutator truing. Plus shipping. A week turnaround.

rodneyadiehl@aol.com

1 Like

If the options with Mike don’t work out, You could go AC motor and controller, it would be a really nice upgrade for about the same money. :slight_smile:
But listen to what Mike has to say - he knows what he doing.